Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Unity Greeter/LightDM is working fine in Precise with one exception.

When the greeter first displays the default system wallpaper /usr/share/backgrounds/warty-final-ubuntu.png is visible for 1 second, before dynamic LightDM kicks in. Its more of a nuisense than anything, but what options do I have to configure this to make it run seamlessly?

I have looked at other related AU Q&A and UF with no success and I have reviewed the configuration at

gksu gedit /etc/lightdm/unity-greeter.conf

share|improve this question
    
perhaps you can clarify - are you asking how to turn off "dynamic" lightdm wallpaper? –  fossfreedom May 2 '12 at 15:13
    
No, I really like this feature and the answer to turning it off already exists here. What I am trying to resolve is this. My chosen desktop wallpaper appears dynamically (No issues here) before it is displayed there is a split second when the default wallpaper is displayed. This happens for all logins. Its not a showstopper its just an inconvenience/a nusience and I thought someone out there may know how to fix it. Every thing else works great –  Stephen Myall May 2 '12 at 15:23

1 Answer 1

up vote 2 down vote accepted

Change the wallpaper to match your "dynamic" backgoroud or, change it to - something like a black, or dark purple background so you don't notice the switch, How do I change the wallpaper in LightDM? , otherwise you will notice when it changes from the default to your dynamic.

Maybe its a bug, who knows? If you turn off the dynamic wallpaper it will still show a transition from a purple background to a custom wallpaper.

Note to benefit others: Answer accepted as it improved LightDM transition, however it did not fully resolve the issue. Complete resolution would be nice, its a "paper over the cracks" solution (the black background).

share|improve this answer
    
Thanks, its a "paper over the cracks" solution (the black background) but one I may have to resort to if there is no fix. I wonder if I am the only one with this issue, if not maybe its a bug, who knows? –  Stephen Myall May 2 '12 at 19:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.