Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use the Microsoft Natural MultiMedia Keyboard 1.0A. The keyboard is not a wireless board. The Escape button and the function keys have never worked. I am currently running on 10.10. On previous incarnations the keys never worked either. However a recent journey through all the Microsoft options in System > Preference > Keyboard > Layouts suggested that the Escape button could be functional. The current setting is Generic 105-key (Intl) PC. Can I find out whether the keys can be made to work or not?

Of the top buttons, nothing happens when I press My Documents; a small red cross appears at the top right of the screen when I press My Pictures and the Media, Mail and Web/Home buttons work just fine.

Thanks, Anthony.

share|improve this question

That looks like one of those non-standard keyboards where you have to press the F-lock key before you can press a function key? Doesn't that work?

share|improve this answer
F-Lock activates some of the keys. That's a first ever. But Close, Reply, Escape, Forward do not respond. Thank you for response. – Anthony Burman Nov 14 '10 at 5:28
A little closer. Can anyone take me further? – Anthony Burman Nov 16 '10 at 4:39
By "not respond", do you mean nothing shows up if you try to use them in the Keyboard Shortcuts dialog? – JanC Nov 16 '10 at 9:00
1)Nothing happens when I click on (some of) the keys after engaging F-Lock. 2)It really looks like I don't know how to use Keyboard Shortcuts. If for example I wanted to press the Open or Spell or Forward Or Undo keys, which do not work, how would I activate those and the remaining Function keys in Keyboard Shortcuts? – Anthony Burman Nov 16 '10 at 17:37
I'm not sure, but I think at least some of these keys are supposed to mimic other keys. E.g. I think Undo is supposed to send Ctrl+Z and Spell is supposed to send whatever shortcut MS Office uses to start a spell check (of course on linux you might want it to send something else, e.g. whatever key OOo uses for that). This has to be done in the keymap and not as a shortcut, and probably means the keyboard needs to be recognized as a "Microsoft Office Keyboard" variant by the kernel and/or by udev (I seem to remember those are implemented in a weird way). – JanC Nov 17 '10 at 6:47

your last question was: "Okay,let's put it this way. My keyboard is a non-wireless Microsoft Natural Multimedia Keyboard 1.0A. How do I get the kernel to recognise the keyboard? – Anthony Burman Nov 22 '10 at 19:57"

From what your saying the problem however doesn't seem to be that the keyboard isn't recognised. You say that you get a red cross when you press pictures. that means Ubuntu get's input but just cannot comply.

The suggestion above is correct but perhaps brief. let's take the "my pictures key". if you want it to open shotwell when you press "pictures key" you should open System>Preferences>Keyboard Shotcuts and click "add" in the bottom. A screen pops up where you can enter the command: in the case of shotwell this will be: /usr/bin/shotwell

By default it will still be disabled but if you click "disabled" you can than press the button on your keyboard that you want to associate.

(for other programs you could try to locate them in the terminal: locate program-name |grep bin (you will than have to choose the one in /usr/bin or /bin) if you want to boot a certain gnome applet you could try: locate gnome |grep bin ,it will show you a lot of gnome applets, names should be pretty explanatory.)

share|improve this answer
> Wow. I had a shot at that and ran into some walls. – Anthony Burman Feb 6 '11 at 15:08
@ bacon. I ran into a wall there.1) With the My Pictures key, I added the command \usr\bin\shotwell. When I pressed the My Pics button a popup read "The shortcut XF86 Touchpad Toggle is already used for Launch Help browser." The Help button doesn't work either.2)I entered program-name| grep bin in the terminal and received answer 'command not found.' 3) I entered locate gnome| grep bin and received a mass of info which I could not /usr/bin/gnome -codec- install or usr/bin/gnome - help. Thanks for responding. – Anthony Burman Feb 6 '11 at 17:06
Hey Anthony, your definitely on the right track. ad 1) you have to make a choice there, if you want that button to start shotwell you should just reassign it. (this means btw that the previous cross meant that help browser couldn't be launched. ad 2) sorry i was unclear there, the command is "locate" you can than input the program you want to find say firefox so "locate firefox" looks for all files or folders with firefox. The grep command helps narrow it down. ad 3) I understand it can feel like a lot of output, but if you want to know what a command does you can test it in the terminal. – bacon Feb 6 '11 at 17:34

It should be possible to go to System->Preferences->Keyboard Shortcuts and select your wished action.

For example select "Home folder" and press your My Documents button if you wish to open your home folder with this key.

share|improve this answer
I selected "Home Folder" and "My Docs" button now works! However the function keys remain silent. – Anthony Burman Nov 13 '10 at 19:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.