Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Gnome classic in Ubuntu 12.04 and I'm not able to find the settings that would allow me to display the date and day along with time in the clock of my indicator applet. Any idea how I can make the date and day appear along with the time?

When I click on the clock and then click on "Time and Date settings", I get the "System settings". From there when I click on "Date and time", I get a setting where I can just edit the date and time. I'm using 12.04 with Gnome classic. I removed unity.

share|improve this question

1 Answer 1

up vote 47 down vote accepted

Using dconf-editor you can set various options to control the indicator-datetime applet

enter image description here

Navigate to com.canonical.indicator.datetime and tick the two checkboxes shown.

dconf-editor is part of the dconf-tools package which you can install from the Software Center or via a terminal command:

sudo apt-get install dconf-tools

If the date does not appear then check that you have the indicator-datetime package installed (logoff and logon after installing the package)

Install indicator-datetime

Later versions of Ubuntu sometimes do not show the path shown in the picture. You'll need to manually set one of the keys first before the path is shown in dconf-editor

For example:

gsettings set com.canonical.indicator.datetime show-clock true
gsettings set com.canonical.indicator.datetime show-day true
gsettings set com.canonical.indicator.datetime show-date true
share|improve this answer
6  
Thank you so much. Very nicely written answer. I installed dconf-tools and have got the day and date along with the time using the gconf-editor. –  harisibrahimkv May 2 '12 at 11:12
3  
It's sort of dumb not to include the date by default. I am not trying to sound hash, but it is true. But thanks for the tips! –  CppLearner Dec 28 '12 at 20:25
    
is there any way to add the year too? I don't see any options –  MNVOH Oct 4 '13 at 12:37
    
It's especially dumb that you have to be root for just a simple setting like this since dconf-editor is not part of the default installation. –  Thomas Mar 17 at 10:11

protected by RolandiXor Feb 20 '13 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.