Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a login list with faces and the icons and text are tiny in GDM. Is there an easy way to change the resolution of the login screen? I'm currently using 10.04 Lucid.

share|improve this question
1  
I think it was not in the 10.04 version but in the 10.10 there is an option called "make default" which changes the resolution of the GDM also. –  Gaurav Butola Nov 13 '10 at 16:20
    
An option where? –  Pointy Jul 2 '11 at 13:21

3 Answers 3

up vote 5 down vote accepted

Gaurav has the right solution for Ubuntu 10.10 (use "Make Default" in System > Preferences > Monitors), however this requires a bit more work in Ubuntu 10.04 LTS. It also means your GDM will have the same resolution as your desktop's.

First find out which resolution your display can take and what its name is. In the following example my laptop display is LVDS-1 and its rated resolution is 1280x800:

$ xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096
LVDS-1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x800       60.1 +
   1024x768       59.9* 
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8  
VGA-1 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
TV-1 connected (normal left inverted right x axis y axis)
   720x576        50.0 +
   1024x768       50.0  
   800x600        50.0  
   720x480        50.0  
   640x480        50.0  
   400x300       100.0  
   320x240       100.0  
   320x200       100.0  

Note in the above output the resolution currently used is marked by an asterisk (*). Next you want to test if such resolution works and find the right command to set it up:

xrandr --output LVDS-1 --mode 800x600x32

In the above command you can change the depth (32 bit) for 24.

Next you want to add such command to the /etc/gdm/Init/Default file before /sbin/initctl ... [1]. The beginning of such file will look like this:

#!/bin/sh
# Stolen from the debian kdm setup, aren't I sneaky
# Plus a lot of fun stuff added
#  -George

PATH="/usr/bin:$PATH"
OLD_IFS=$IFS

#if [ -x '/usr/bin/xsplash' ];
#then
#        /usr/bin/xsplash --gdm-session --daemon
#fi

xrandr --output LVDS-1 --mode 800x600x32
/sbin/initctl -q emit login-session-start DISPLAY_MANAGER=gdm

Once you've done this you can logout to see the results. I tested this in a VM environment only but it should work on a standard install ("bare metal").

[1] https://wiki.ubuntu.com/X/Config/Resolution#Setting%20xrandr%20commands%20in%20kdm/gdm%20startup%20scripts

share|improve this answer
    
Thanks, in my "what happened" answer. I was just stating a fact along with the recognition that I don't know exactly what changed in the xorg.conf file. MagicFab as I would expect your answer does offer the same results and I'll accept it unless someone has one that better qualifies as "easy". However can you give a really quick explanation of why it is better to use this method than the xorg.conf changes. If I was talking to someone who wasn't comfortable with the command line and had an Nvidia card I would still be tempted to send them the GUI route unless there is an unforeseen danger. –  Dennis Nov 29 '10 at 13:56
    
The method I described should work for all graphic cards. The method described by Dennis works only with NVidia binary drivers, which come with the nVidia config tool which happens to generate / modify xorg.conf etc. - unless you want to dig into xorg.conf syntax, which is another option. –  MagicFab Dec 15 '10 at 1:02
    
I'm having the same problem as the OP in Natty, but this solution is ineffective. In fact I added a debug call to xrandr in the Init/Default script, and it logs the normal setting for the monitor, with 1366x768 resolution. Nevertheless, the login screen is stuck at 1024x768. I even added the monitor setting app to the login window setup, and it won't allow any resolution except the three "safe" ones (1024x768, 800x600, 640x480 I think). –  Pointy Jul 2 '11 at 13:21

OK for me the answer was in the xorg.conf file. I don't even know exactly what the pertinent lines are, but previously I didn't have a /etc/X11/xorg.conf file. Because I didn't want to screw anything up I didn't really investigate it. After installing a new video card and switching to the Nvidia binary drivers I used the configuration tool to change the screen resolution. However it was not persistent between logins so I tried the "Write settings to xorg.conf file" button. Next time I logged out the user login menu had the same resolution as all the other users screens. I'm sure this would be a problem if everyone wanted different resolutions but for me that isn't the case.

share|improve this answer

It can be a isolated problem with the current theme. Which theme you are using now in GDM? Did you check if you have the same problem with others themes?

You also can try to reconfigure your GDM using the commands (You will lose your X11 session doing so) below:

$ sudo dpkg-reconfigure gdm
$ sudo /etc/init.d/gdm restart . 

You may need to run the gdmsetup (just works for Ubuntu before 2010):

  • Press Alt + F2, type gdmsetup and press Enter (will open a desktop application).
share|improve this answer
    
Latest ubuntu version are using a different gdmsetup tool. None of the current or previous gdmsetup tools allow you to change the resolution. –  Adi Roiban Nov 13 '10 at 15:32
    
He did not have mentioned the Latest Ubuntu (he is using 10.04 Lucid). Anyway, gdmsetup is not useful... I'll fix my Answer. Thanks! –  crncosta Nov 13 '10 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.