Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Before someone marks this question as duplicate : I have tried the common fix for this problem by installing the 295.33 series driver as suggested elsewhere.

I have also removed my compiz-1 settings and .compiz-1 and .compiz and started afresh.

Despite all this Unity 3d works snappily only in the guest-session.

In my regular session, the performance is terribly slow. Window dont erase..moving the terminal around gets hundreds of ghosted windows. The Guest-session on the same machine has seemingly flawless Unity performance ( it was so good I check by echo $DESKTOP_SESSION and it was indeed Unity 3d).

What in my setup is causing slow laggy performance as the non-guest user? Just deleting the .config/compiz and .config/compiz-1 and ~/.compiz and ~/.compiz-1 settings doesnt seem to sort out my compiz settings and give me guest session like performance.

share|improve this question
I am now started to think that it will be better to avoid installation but keep a live system on usb with customized Ubuntu than getting fed up with "unity virus".I wont prefer to make start up disk as it need more time to get load and to shutdown.I would make a live system by this way with an ISO created by UCK.(Just type UCK in Software Center).It saves so much of our valuable time. – beeju May 2 '12 at 10:15

I finally solved the problem.

I deleted my entire ~/.config directory. Logged out and logged back in. Ubuntu 3d now works perfectly with the unpatched 295.33 driver.

I will diff the two .configs to find out what was causing the laggy performance..but my guess is that it was something outisde of compiz since deleting just the compiz entries didnt fix the slowness.

share|improve this answer

I had the same issue. Laggy interface on ubuntu 12.04 with 295.33 driver. Deleting .config .compiz and .compiz-1 directory worked

share|improve this answer

I was stuck with Unity and Compiz too since my update to 12.04, my desktop was to laggy/slow and unusable. Here is the fix:

Launch compiz config manager ccsm and uncheck ubuntu unity.

Add to the startup program : /usr/bin/gnome-panel to have the usual gnome taskbar.

Don't forget to enable other features while you are in the ccsm like window resize, window switch (I'm using the shift switcher, because the app selector freezes everything..), ...


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.