Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason (having used xorg-edgers in the past might be part of that), I still have a very old X server installed:

xorg   7.6+7ubuntu7.1
xserver-xorg-core  1.10.4-1ubuntu4.2
xserver-xorg-video-intel  2.16.0+git20111011.823a4272-0ubuntu0sarvatt~natty

when I try dist-upgrade, aptitude wants to remove 255 packages first (acrobat, bluez-alsa, ..., ia32-libs, ..., xserver-xorg-video-* to name a few)

Is there a way to update packages forcing Ubuntu to ignore any dependencies it might think that could theoretically be violated?

On a RPM-based system, I'd use rpm --force --nodeps

Note: I already removed the xorg-edgers ppa.

Note 2: I'm trying to upgrade with aptitude safe-upgrade and aptitude dist-upgrade

share|improve this question
    
Forcing to ignore dependencies is always a bad idea as I have just experienced from the systems in my lab. Unless you are sure what you are doing, don't do it. –  harisibrahimkv May 2 '12 at 9:37
    
Well, I'm 100% sure Ubuntu is getting it wrong so what options do I have? I could probably download the source packages and rebuild them without dependencies ... –  Aaron Digulla May 2 '12 at 9:39
    
Brrr.. This is sending a shiver down my spine. I believe it is best to wait for an expert opinion on this. :) –  harisibrahimkv May 2 '12 at 9:42
add comment

2 Answers

up vote 0 down vote accepted

It seems that aptitude contains new code to resolve dependencies. This code is ... could be better. :-)

In my case, running apt-get upgrade just offered to upgrade the 13 xorg packages and leave the rest of my system alone.

So if your aptitude hangs itself in the dependency graph (= when installing/upgrading, it wants to remove hundreds of packages first), give the old tools another try.

share|improve this answer
add comment

Only way i know for holding is using aptitude, where you can set packages to hold. The only problem is, that you should further use aptitude for every updating/installing/removing task, because AFAIK other package manager tools does not care about hold-flags. In apt-get docs is also option --ignore-hold, but at least last time i used apt-get with hold-flags set to some packages, it ignored them anyway.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.