Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was very satisfied with Ubuntu Customization kit on Ubuntu previous versions but with 12.04, it leads to crash zenity and disappear the GUI and nothing occur.I tried the old version of this package but the same result.Please help me.Thnx in advance.

share|improve this question
    
can you please repost because link doesn't work. Thank you. –  user164033 Jun 3 '13 at 6:44
add comment

1 Answer 1

I had no idea what Ubuntu Customization kit was, but I downloaded it so as to help you and I found out what causes the bug, I also found a solution to the problem, after a 5-6 min search of the code. So, with some tricks on the code I managed to go till the screen that asks for the ISO, but I couldn't go further, as I didn't have an ISO downloaded, but I suspect that it should work fine from that point and after.

Ok, follow these steps:

  1. Open a terminal (using Ctrl+Alt+T) and give: gksudo gedit /usr/lib/uck/gui.sh

    Gedit will open.

  2. Now, replace all the text in the opened file with this text: http://paste.ubuntu.com/961943/ (DO NOT select the numbers on the left)

    Save the file and close gedit and terminal.

  3. Re-run UCK.

Please let me now if it works further than selecting the ISO image, because I've tested till that point only (cause as I said before, I don't have an ISO to test it out!)

Also, note that this is not a permanent fix, it will probably cause some bugs in case you click 'Cancel' etc, but it will at least not crush and let you do the work.

share|improve this answer
    
Thank u hakermania, u have done a marvelous job for me.Right now I am away from home but will conquer it with what u said and post the reply here as soon as I reach home.But let me say that it runs up to it allows me to select the language for the ISO but disappears the moment I click "ok" and only the message comes out as "the application zenity closed unexpectedly". –  beeju May 2 '12 at 10:00
    
Yes beeju, the same happened to me, but I fixed it and it doesn't crush (closes unexpectedly) at least till the point that asks for the ISO file! –  hakermania May 2 '12 at 10:05
    
I am so pleased.I don't know what all those texts you wrote on pastbin.I just entered my password for the build.It works!!! –  beeju May 2 '12 at 11:34
    
But it failed at last.I went through all the lines on terminal before I close it.From this paste.ubuntu.com/962187 I thought the temp folder in my Home folder made this problem.So I removed it from there.On running the package,it failed again and I deleted both resolvconf folder and resolv.conf with root power.Now it said this paste.ubuntu.com/962263 –  beeju May 2 '12 at 12:33
    
Sorry, I don't know anything else about this :( –  hakermania May 2 '12 at 13:41
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.