Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Now when I switch on the computer, only black screen with the following message shows up:

"Could not write byte: broken pipe" ..... Starting network connection Stopping network connection (the above phrases repeat many times)

Also something like:

Stopping System V runlevel

I cannot type on the screen. It doesn't proceed onto anything. Just hanging there.

Please help! If there's anything I can do to enter and get my files.

Thank you!

share|improve this question
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro May 15 '12 at 13:34
add comment

closed as off topic by fossfreedom May 15 '12 at 13:56

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

It happened to me also. I'm not sure what was the source of this as I did an upgrade, installed some apps and changed themes and icons. Deleting configuration folders from home folder solved my problem, so you should give it a try.

  1. Press CTRL+ALT+F1 key combination.
  2. Log in using TTY.
  3. Delete those folders: .config, .cache, .dbus, .gfvs, .local with rm -R command.

Example:

rm -R /home/user/.config

I'm not sure if all listed folders should be deleted, so you can try one by one. If it solve your problem and you'll able to log in, be prepared for tons of Apport windows ;)

share|improve this answer
    
I had the same problem. My system just completely froze during normal use (I just pressed back in a menu in xbmc) and start lightdm just gets stuck on the above error message. This solved it! Thanks! –  xster Nov 27 '12 at 3:37
add comment

I had the sam problem which is caused by an error in var/lib/dpkg/status from a third party package. In this file the status of the update is saved and if there is an error somewhere the following packages are not installed.

Please follow the following steps which helped me (original source: http://forum.ubuntuusers.de/topic/dpkg-configure-a-schlaegt-fehl/ ) :

  • boot normally, not recovery mode and click Str+Alt+F1 to start the terminal input.
  • log in with your password and username
  • type: sudo apt-get -f install
  • you will get a message saying that there is an error in var/lib/dpkg/status and a line where the error is located.
  • use the nano editor (sudo nano -w) to find the package around the line named in the error message and delete the package which causes the problem (more than one line). be careful and only delete the package which causes the problem!
  • likewise delete the same package from the file /var/lib/dpkg/available -run sudo apt-get -f install again and it will run through this time.

this solution is from http://forum.ubuntuusers.de/topic/dpkg-configure-a-schlaegt-fehl/

share|improve this answer
    
After you completed all the steps you should do: sudo apt-get update and sudo apt-get upgrade . –  Malte May 2 '12 at 18:07
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.