Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having installed MyUnity, it also shows up as an entry in the System Settings dialog. However, the System Settings window does not adapt to it. Now I have to scroll down to see the bottom entries, because the System Settings window is not resizable, nor can it be maximized. Is this a bug? There's still plenty of space on my screen. So why scroll down? Is there a way to make this window resizable/maximizable or adapt to the number of entries?

See image: enter image description here

Note: I have disabled overlay scrollbars. But that has nothing to do with it. It also doesn't work with overlay scrollbars enabled.

share|improve this question
add comment

3 Answers 3

You can force the resize ability by editing the file /usr/share/gnome-control-center/ui/shell.ui and changing:

 <property name="resizable">False</property>

to

 <property name="resizable">True</property>
share|improve this answer
    
That worked..!! thanx!! –  Nirmik May 23 '12 at 13:46
    
Thank you! It is resizable now, but the icons don't fit to the new size when it is bigger and you can't make the window smaller. Also, it doesn't remember its size after closing. So this seems not to be the solution which was asked for. :-( –  Jakob May 23 '12 at 14:15
add comment

This inconsistency also annoys me and I found a little workaround continuing from Henrique's post.

Edit this file:

/usr/share/gnome-control-center/ui/shell.ui

In the beginning you will see these lines:

<object class="GtkWindow" id="main-window">
<property name="title" translatable="yes">System Settings</property>
<property name="resizable">False</property>
<property name="icon_name">preferences-desktop</property>
<property name="window_position">center</property>

Add this line after the last property to open the window with a fixed width:

<property name="width_request">1000</property>

Or a line indicating a fixed height:

<property name="height_request">760</property>

And modify the resizable line to:

<property name="resizable">True</property>

This will fix the width to 1000 pixels (or height to 760) or whatever you enter and make the window resizable. It won't remember anything when you resize though. It will always open at 1000 px width or 760 px height. But at least the damn scrollbar is gone and all icons are visible.

Now there is a glitch with this width/height request thing. The main window will open at the requested height, but when you then select a setting like "Appearance" and then go back to "All settings" using the top button, the scrollbar is back and the main window is smaller again. Back to start.

You can circumvent this behaviour by placing the height_request line inside the "GtkVBox" section instead of the "GtkWindow" section as we did above. So look for:

<object class="GtkVBox" id="vbox1">
<property name="visible">True</property>
<property name="orientation">vertical</property>

And add the line:

<property name="height_request">760</property>

in this section. You can remove the line from the "GtkWindow" section then. The new glitch here is that every setting window will be opened at 760 px height and won't be scaled to fit.

So it's up to you what you prefer. :)

cheers peepz.

share|improve this answer
add comment

You can't resize it. The problem is described in this bug report already, and was linked to this bug report. You can mark there that it affects you, too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.