Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I installed Ubuntu 12.04 on my laptop. And I found that when I left my laptop suspend mode, the Compiz hold CPU at 100% all the time until the laptop woke up.

Can anyone tell me what is happening?

share|improve this question
    
Hi, and welcome to AskUbuntu. The question is somewhat vague. Can you explain how you checked CPU usage when the computer has been suspended. –  mikewhatever May 2 '12 at 4:14
    
hi, mike.At first I just notice the sound that CPU worked too busy when suspend.Then I started a "top" command and waited for the notebook go into suspend and I find the "compiz" process hold CPU 100% all the time.Apologize for my pool English.:) –  Boris May 2 '12 at 4:23
add comment

3 Answers 3

What video card do you have? What driver are you using?

There's a number of bugs that a Google search turns up.

For the 2nd one, a possible solution is to disable the file watcher plugin in ccsm. However, this plugin is not enabled by default, so that solution may not apply.

For the 3rd one, a suggested workaround is to enable either the "Force full screen redraw" or "Vertical synchronization" options in ccsm.

Do any of those bugs seem related?

share|improve this answer
    
Hi, I have ATI radeon Mobility HD5650 on my notebook, using the driver provided in the "Additional drivers".The problems did not happen when I used ubuntu 11.10 last week. –  Boris May 2 '12 at 4:19
    
I will have a look on the links you suggested.Thanks. –  Boris May 2 '12 at 4:35
1  
@Mikel The workaround in the 3rd bug worked for me by enable "Force full screen redraw" –  Chris Carter Jul 1 '12 at 10:04
add comment

Had the same problem on HP Pavilion dv6 with ATI Radeon HD5000 series card. It does seem to be the same as this.

The solution for me was as stated above to "Force full screen redraw" via ccsm and to follow the steps in the workaround 1 on the bug report itself.

share|improve this answer
add comment

I have the same issues with cpu usage because of compiz. My workaround was to switch session from Ubuntu to Ubuntu 2D.

ubuntu 2d

share|improve this answer
1  
Why down-voted? –  Eugene Manuilov May 28 '12 at 14:39
2  
upvoted - think this was a useful suggestion though there may be better options available. Downvoting without sharing useful suggestions is lame. –  ali haider Sep 10 '12 at 14:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.