Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought an Asus K54L and immediately installed Ubuntu 11.10 along side of Windows 7. The touchpad was working in both Windows and Ubuntu, but after restarting a couple of times (after updates and installations, etc.) and all of a sudden the touchpad was stuck in the left-click mode. I checked and it's now happening in Windows, too. The only updates I was able to do before this happened were apt-get update. I decided to upgrade to 12.04 to see if that would fix it, but no such luck.

I've read a ton of stuff out there about this out there, but I can't seem to find anyone who is having the same problem. Perhaps it's just the hardware? I've never had a problem with this before, and I don't really know how to troubleshoot. Please help

Edit: I restarted Ubuntu last night in recovery mode and ran some clean up script available from the list of options there. When I continued on through the booting process, I found that the mouse worked in this "recovery mode." When I restarted again, it was broken again. I didn't try it in Windows. Do they share the same configuration file or something? I would assume not.

Also, I found this but it's for arch linux, and I'm not sure if it applies to Ubuntu. How should I troubleshoot this?

share|improve this question

closed as too localized by Eliah Kagan, belacqua, Ringtail, Takkat, Thomas W. Oct 27 '12 at 22:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Hmm, I would try shutting down and pulling the battery out for a few seconds and put it back in and start it up. EDIT:

It looks like its a bug that is ASUS specific :( > Elantech Touchpad

share|improve this answer
up vote 1 down vote accepted

This ended up being a hardware problem. Unfortunately the only fix is replacing the motherboard

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.