Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I guess the title says it all... Any ideas as to why? I tried removing potentially offending 32-bit libs (this is a 32-bit title) inside the game's lib32/ folder (I already have 32-bit libs installed). Alas, no dice. The worst part is that the game immediately exits when started without reporting a single error. All suggested fixes on the Frozenbyte forums have yielded no progress.

On a somewhat related topic, other games also exhibit problems, like Crayon Physics Deluxe.

share|improve this question
    
If possible, please consider closing some of your other open questions by selecting the best answer (if they have one). Consider which answers have been useful and need an upvote. We need users to maintain their questions so that the site can be an effective tool for the next person with your problems. For more details on best practices consider reading the FAQ on asking questions. –  fossfreedom Jun 8 '12 at 11:21
    
Unfortunately none of the suggested solutions worked for me. I ended up using Wine which appears to work without a hitch. –  FlabbergastedPickle Jun 19 '13 at 11:33
    
That's great - if you can turn that comment into an answer that someone can follow, you can accept it yourself by clicking the tick button next to your answer - and if its a great answer you should receive a few upvotes as well :) –  fossfreedom Jun 19 '13 at 11:43
add comment

2 Answers

For Crayon Physics, this worked for 12.04 32-bit.

  1. Go to the installation folder and rename lib32to lib32ORIGINAL.

  2. In the terminal run the following command:

    sudo apt-get install libqtcore4 libqtgui4
    

    For 64-bit, try this:

    sudo apt-get install ia32-libs libqtcore4 libqtgui4
    
  3. In the terminal:

    sudo apt-get install libsdl1.2debian libsdl-image1.2 libsdl-mixer1.2
    

    For 64-bit:

    sudo apt-get install i32-libs libsdl1.2debian libsdl-image1.2 libsdl-mixer1.2
    
  4. cd to the installation folder and execute ./launcher.

I hope this works for you!

share|improve this answer
1  
Tried your fix, I get: "./launcher: error while loading shared libraries: libGLEW.so.1.5: cannot open shared object file: No such file or directory" –  fleamour Nov 8 '12 at 19:07
add comment
up vote 0 down vote accepted

Unfortunately, as stated above, it appears that so far the only way to run Shadowgrounds under Linux is by using Wine. As far as I can tell the game behaves normally under Wine and is perfectly playable. That said, it would be still nice if someone came up with a way to play it natively as well... Given that htere has been no activity for over a year, I am proposing this to be the best answer we got at this point. Should anything change, I will gladly assign the answer to a better answer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.