Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't get my shortcuts to work, among other things in 12.04.

Anyone else with this problem? I'm not very pleased with Ubuntu 12.04 so far. What a letdown!

share|improve this question

closed as not a real question by Jorge Castro, Tom Brossman, Javier Rivera, hhlp, Salem Dec 31 '12 at 16:20

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What shortcuts? What happens when you tap super? Is your keyboard working? –  Jacob Johan Edwards May 2 '12 at 1:41
    
Hold down the Super key to get a list of default shortcuts for 12.04. Perhaps some of them were changed when you upgraded/installed. Also note that there are a few bugs with 12.04 right now regarding shortcuts and certain shortcut actions , Super+W comes to mind. You can check current bugs at (bugs.launchpad.net/ubuntu/precise) –  James May 2 '12 at 2:41
1  
Yeah, Super+W makes my computer spazz out lol When I hit super, the app menu thing shows up like normal. What I'm talking about specifically is getting Rhythmbox to jump to the next song. My keyboard doesn't have a "Next" button (only play/pause and volume), so I had assigned Super+N to be "Next" and Super+B to be "Previous" but that wouldn't work so I did Alt+N and Alt+B which works most of the time. It's working again after reboot, but it intermittently stops working. –  Bradley Peterson May 2 '12 at 3:09
    
When I press and hold Super, the menu pops up as Jacob Johan Edwards said, but it doesn't show "Media" shortcuts on there anywhere. In any case, I got it working again, but only with a reboot and assigning the shortcut to something else, then BACK to Alt+B and Alt+N. I was disappointed that I couldn't keep my Super+N and Super+B shortcuts :( –  Bradley Peterson May 2 '12 at 3:14
    
Assigning Super to user shortcuts seems to be broken in 12.04 right now. –  James May 3 '12 at 2:33

5 Answers 5

I finally managed to get my shortcuts back, including the ones with Super.

1) Map the Super key

In System Settings / Keyboard / Typing tab / Layout Settings link (at the bottom) / Layouts tab / Options button / "Alt/Win key behaviour", choose Meta is mapped to Left Win key.

2) Desktop Shortcuts (such as "Show Desktop")

a) install dconf-tools: sudo apt-get install dconf-tools

b) run dconf-editor, go to /org/gnome/desktop/wm/keybindings and change the values you want to change. I set my shortcuts like in Windows:

  • panel-run-dialog is the run command, I set it to ['<Super>R']
  • show-desktop is to show the desktop, I set it to ['<Super>M']

3) Other Shortcuts (such as "Launch Terminal")

a) In System Settings / Keyboard / Shortcuts tab / Custom Shortcuts, Add (with the '+' button) all the shortcuts you want and set their accelerator. If you want to use the Super key here, you should use the Super here but it won't work yet

b) run gconf-editor (with a 'g', not a 'd' like 2.a), go to /desktop/gnome/keybindings and for each shortcut that uses Super, change Super to Mod4

That's it!

share|improve this answer

Any custom keyboard shortcuts involving Super button don't work in 12.04. For example, when I set a key combination Super+L to lock the screen - it doesn't do it (although it shows this combination in the menu by the "Lock Screen" menu item).

This is a regression from 11.10, where these key combinations worked flawlessly...

share|improve this answer
    
Okay, I'm happy with using Alt instead of Super, I just have to relearn that muscle memory haha. No big deal.. –  Bradley Peterson May 2 '12 at 4:20

To get my media keys (volume up, volume down etc.) working in Ubuntu 12.04, I had to run dconf-editor and go to org -> gnome -> settings-daemon -> plugins -> media-keys and check the "active" box.

share|improve this answer

A work-around for shortcuts to run commands is to use compiz's commands plugin. Using this plugin I was able to make my custom Super-shortcuts working again which did not work with the standard Keyboard -> Shortcuts system settings.

Still this solution does not seem to work for shortcuts used by Unity. For example it's not possible to override Super-T, which opens the trash even if it has been re-assigned to something else in the commands plugin. And I couldn't find a way to disable the default action as defined by Unity.

share|improve this answer

I don't think it works with Unity but I have a solution which works at least for those who use Gnome. If you still don't have dconf-tools install it. Open it and go to org -> gnome -> desktop -> wm -> keybindings. There you can edit all the desktop shortcuts

share|improve this answer

protected by Community Dec 31 '12 at 11:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.