Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How I can uninstall and reinstall moonlight?

share|improve this question
up vote 1 down vote accepted

If your browser reports that "moonlight" is "disabled" due to incompatibility, then here is what you need to do:

Make a backup copy of .mozilla (/home/your_user_name/.mozilla) before proceeding. This will preserve important bookmarks and other things you might want to consider later.

Now delete the .mozilla folder from /home/your_user_name/ and then reinstall all the addons and search plugins you had.

Now go to and again install moonlight from there.


1) .mozilla is a hidden folder. Press (ctrl+h) to see it.

2) You can restore your bookmarks from backup of .mozilla


This "om8xf96h" will look diffrent on your system. To restore open Bookmarks Window then use the "Restore" option from "Import and Backup" menu. Click on Restore and then navigate to backup directory and select the last modified .json file (like "bookmarks-2012-05-02.json")

4) To restore search engines (search plugins) copy the "searchplugins" folder from mozilla/firefox/om8xf96h.default/ and paste it to /home/your_user_name/.mozilla/firefox/om8xf96h.default

share|improve this answer

It seems that moonlight is discountinued for linux. You could force Firefox to enable moonlight but there are known security issues and youre at your own.

share|improve this answer
I have solved this issue. Now moonlight is working well. – Curious Apprentice May 2 '12 at 3:31
@CuriousApprentice how did you solve it? You can post the solution as an answer to your own question and accept it – amc May 2 '12 at 4:42
Yeah! I have done that. Thanks for the reply. – Curious Apprentice May 2 '12 at 6:19

Actually you simply have to reinstall the MoonLight Add-on from the web site and restart firefox to make it work again.

share|improve this answer
It did not worked that way. I tried it on the first hand. – Curious Apprentice May 6 '12 at 7:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.