Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed eclipse with sudo apt-get install ubuntu but when i try to install OCAIDE with Help->Install New Software. Appears this error :

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: org.eclipse.update.feature,OcaIDEFeature,1.2.15.201204281554.
http://www.algo-prog.info/ocaide/features/OcaIDEFeature_1.2.15.201204281554.jar
Artifact not found: osgi.bundle,Ocaml,1.2.14.201204281554.
http://www.algo-prog.info/ocaide/plugins/Ocaml_1.2.14.201204281554.jar

Can you help me? Im desperate because i need this for a college work.

share|improve this question
    
You should try using the eclipse version from their web page, because eclipse can be sensitive about it's components when it comes to installing new plugins. –  danizmax Aug 29 '12 at 9:02
add comment

1 Answer

Here's how it worked for me

Install both eclipse and eclipse-pde. These are the packages I have installed:

sudo apt-get install eclipse eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rcp

Add the site: http://eclipsefp.sourceforge.net/ocaml/site.xml as a software source

Help->Install New Software
Select OCaml

You get this:
enter image description here

I suspect you're missing something that's in these:
eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rcp

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.