Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having some difficulty getting sound to work on my Ubuntu machine. I am trying to keep my installation as thin as possible (older machine), so I started off with Ubuntu Server 12.04 and installed only what I needed. Everything is going well, except for sound.

I ran sudo apt-get install alsa-base alsa-utils and that installed correctly. I can also run alsamixer (as root...not sure why I can't do that as a user) and it seems to see my Intel card. (HDA Intel, SigmaTel STAC9227). All channels appear to be unmuted within alsamixer.

Here is the output that I think is relevant.

lsmod | grep '^snd' | column -t

snd_intel9x0        38570   0
snd_ac97_codec      134826  1   snd_intel8x0
snd_hda_intel       33773   0
snd_seq_midi        13324   0
snd_rawmidi         30748   1   snd_seq_midi
snd_seq_midi_event  14899   1   snd_seq_midi
snd_seq             61896   2   snd_seq_midi,snd_seq_midi_event
snd_seq_device      14540   3   snd_seq_midi,snd_rawmidi,snd_seq
snd_hda_codec_hdmi  32474   1
snd_hda_codec_idt   70795   1
snd_hda_codec       127706  3   snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_idt
snd_hwdep           13668   1   snd_hda_codec
snd_pcm             97188   5   snd_intel8x0,snd_ac97_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec
snd_timer           29990   2   snd_seq,snd_pcm
snd                 78855   12  snd_intel8x0,snd_ac97_codec,snd_hda_intel,snd_rawmidi,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc      18529   3   snd_intel8x0,snd_hda_intel,snd_pcm

and:

ls -l /dev/snd/

total 0
drwxr-xr-x 2 root root       80 May  1 19:35 by-path
crw-rw---T 1 root audio 116,  5 May  1 19:35 controlC0
crw-rw---T 1 root audio 116,  8 May  1 19:35 controlC1
crw-rw---T 1 root audio 116,  4 May  1 19:35 hwC0D2
crw-rw---T 1 root audio 116,  7 May  1 19:35 hwC1D0
crw-rw---T 1 root audio 116,  3 May  1 19:35 pcmC0D0c
crw-rw---T 1 root audio 116,  2 May  1 19:35 pcmC0D0p
crw-rw---T 1 root audio 116,  6 May  1 19:35 pcmC1D3p
crw-rw---T 1 root audio 116,  1 May  1 19:35 seq
crw-rw---T 1 root audio 116, 33 May  1 19:07 timer

update based on comment

lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV770 HDMI Audio [Radeon HD 4850/4870]
share|improve this question
    
what output you are getting of lspci | grep Audio? –  ashutosh May 2 '12 at 0:04
    
@ashutosh - Added the requested output. –  JasCav May 2 '12 at 0:17
    
seems to detect your inputs, now the problem lies in the speakers only which might be a software problem. Just check if it works with realtek drivers here and try to upgrade the package of alsa here –  ashutosh May 2 '12 at 0:23
    
I think I have the latest package of alsa and I have had audio working before on this machine if I do a full install of Ubuntu Desktop (it just runs too slow). Will look at the Realtek drivers. (BTW - Audio appears to play...just no sound is coming out. Very strange.) –  JasCav May 2 '12 at 0:27
    
Tried it out - still unable to get the sound to work. –  JasCav May 2 '12 at 0:43

2 Answers 2

up vote 0 down vote accepted

So, it turns out that I had to add myself to the audio group. I had originally seen (in instructions for Ubuntu somewhere) that I should not do this. However, I can't seem to get audio working any other way.

If someone has another suggestion because they think I am doing this wrong, then please let me know. Otherwise, I'm going to mark this as the answer.

share|improve this answer

I had the same problem on a Gateway gx7022e (SigmaTel STAC9221 A1) running Ubuntu 12.04 and had to do the following:

  1. Add options snd-hda-intel model=gateway to the end of /etc/modprobe.d/alsa-base.conf
  2. Add myself to the audio group as you suggested
  3. Reboot

While this does not allow the front audio port to work, the rear one does.

This does not get HDMI audio working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.