Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I tried to upgrade to 12.04 and then tried a complete install.

Each seemed to progress correctly, but the same thing happened afterwards in each case.

When the system is rebooted, I see the Ubuntu screen and then the command line for a virtual tty terminal.

Ubuntu 12.04 al-HP-Pavilion-dv9000-notebook-PC-tty1
al-HP-Pavilion-dv9700-Notebook-pc login:

I log in and then get:

Password:

I enter the password and then get:

Last login:  Tue May 1 17:56 CDT (GNU/Linux 3.2.0-24-generic-pae i186)

*Documentation:  Https://help.ubuntu.com/

20 packages can be updated.
8 updates are security updates.

al@al-HP-Pavilion-dv9700-notebook-pc:~PC:~$

At this point, it does not matter what I enter or do, I simply get returned to the last line above this one.

Help!

AL

share|improve this question
add comment

3 Answers 3

Since I am assuming you might have got an upgrade, so there must be a problem with Xauthority file in /home folder. Try logging in by pressing Alt+Ctrl+F1 and delete any instance of the Xauthority files found. Following command can do it-

sudo rm .Xauthority*

Otherwise, enter the command to get gnome session to open:

startx gnome-session-fallback -- :1
share|improve this answer
add comment


What happens if you press CtrlAlt+F7?
(Note: I don't really expect this will "fix" things, but maybe you'll see an error message or other clue as to what is happening?)

Or another direction you might take, can you run the command dmesg when you are signed into this tty1 virtual terminal which comes up when you boot?

share|improve this answer
add comment

I encountered this issue due to a bad ~/xorg.conf and after deleting it, my system booted directly to desktop again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.