Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My default keyboard layout is Norwegian (from the 12.04 installation procedure). But I also want to use Icelandic.

Two layouts in the "system settings" → "keyboard layouts" is one too many. I cannot switch either using a shortcut or in the Panel.

The Panel tells me I have switched, but the letters I type are Norwegian, even when the Panel seems to have switched to Icelandic.

My language for menus and windows ("system settings" → "language support") is English. "Regional formats" → "Display numbers, dates ….": English Denmark,

What am I doing wrong?

share|improve this question

closed as unclear what you're asking by Braiam, bain, Mahesh, qbi, waltinator Jun 24 at 15:44

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What do you mean by "one to many". Please clarify, what have you changed in Keyboard layouts? Do you see a keyboard icon in the upper right? –  Jacob Johan Edwards May 2 '12 at 5:48
add comment

4 Answers 4

Maybe you can try this:

sudo setxkbmap -option grp:alt_shift_toggle no,ru

This maybe can help you but you have to do it everytime you log in to your system. You can add this command to execute

share|improve this answer
    
Yes, Ashutosh! It worked. But is there no file I can open to edit in the line? –  kle May 2 '12 at 15:23
    
If it worked for you, then please make it the answer, file would have been different, so i think there is another file to have that line. PLease make it the answer if it helped you –  ashutosh May 2 '12 at 16:20
add comment

go keyboard settings -> options and from the popup click the arrow at Key(s) to change layout and select the shortcut you need

share|improve this answer
add comment

Add (and install) the layout it is using but move the wanted layout to top on the keyboard layouts list (System settings -> Keyboard Layout -> Layouts). Reboot. Logout. Login checking that the wanted layout is selected in the login screen. Reboot and test if working.

share|improve this answer
add comment

OP-provided answer, probably inspired by @ashutosh


To enable toggling between two keyboards for current session:

  sudo setxkbmap -option grp:alt_shift_toggle no,is  

To permanently set several keyboards (Norwegian, Icelandic, Spanish)

  sudo gedit /etc/default/keyboard  

Edit line 2 thus:

  XKBMODEL="pc105"
  XKBLAYOUT="no, is, es"
  XKBVARIANT=""
  XKBOPTIONS=""
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.