Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just tried xmonad and I'd like to know what is the correct way to avoid the ugly base gtk theme that shows up after a fresh install. I ran into lxappearance but some people were not satisfied it seems. So I thought I'd take some input on the best way to achieve what I want before jumping into it.

My target result is the nice and pretty ubuntu default theme.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I have discovered that the culprit is, in fact, /usr/share/gnome-session/sessions/xmonad.session or equivalent file.

Create or edit the file /usr/share/gnome-session/sessions/xmonad.session to be:

[GNOME Session]
Name=Xmonad/GNOME
RequiredComponents=gnome-settings-daemon;
RequiredProviders=windowmanager;
DefaultProvider-windowmanager=xmonad
DesktopName=Unity

The important line is the last one. DesktopName must have the value Unity, even if you do not use it.

Also, create or edit /usr/share/xsessions/gnome-xmonad.desktop to the following:

[Desktop Entry]
Name=GNOME with Xmonad
Comment=A GNOME fallback mode session using xmonad as the window manager.
Exec=gnome-session --session=xmonad
TryExec=gnome-session
Icon=
Type=Application

At login, choose GNOME with Xmonad from the session dropdown.

Everything, including themes, the desktop background and other minor things should work as expected.

Edit: if this does not seem to work, run gnome-session-properties (Startup Applications) and add gnome-settings-daemon to the list. (It's unlikely that this will work but it's worth a try.)


Update

For newer versions of Ubuntu, try the following for /usr/share/ghome-session/sessions/xmonad.session:

[GNOME Session]
Name=Xmonad/GNOME
RequiredComponents=gnome-settings-daemon;gnome-panel;
RequiredProviders=windowmanager;panel;
DefaultProvider-windowmanager=xmonad
DefaultProvider-panel=unity-2d-panel

If the first doesn't work, I'm not sure this one will, either, but I'd try it anyway.

share|improve this answer
    
Thanks for sharing that :) –  Mog May 10 '12 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.