Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a clean install of 12.04 on my netbook, then installed xubuntu-desktop. (The reason for that is the showstopper bugs in 11.10 Unity -- like menus not working, or the launch bar capturing the mouse and locking up the machine)

Now, the power button does nothing. Attempting to go to power settings from the xcfe4 settings times out.

I checked, and xfce4-power-manager is running, as well as /usr/lib/upowerd.

Trying

sudo xfce4-power-manager --dump

does nothing for a minute or so, then gives me the following message:

ce4-power-manager:4226): xfce4-power-manager-ERROR **: Did not receive a reply. 
Possible causes include: the remote application did not send a reply, the message 
bus security policy blocked the reply, the reply timeout expired, or the network 
connection was broken.
Trace/breakpoint trap (core dumped)

along with the "crash" icon on the top panel, which I've now seen over 30 times in approximately 8 hours of uptime.

I'd be very interested in knowing how to get back up to the level of functionality that I had with 11.10 on this netbook.

share|improve this question
    
This bug report on Xfce's site looks relevant: bugzilla.xfce.org/show_bug.cgi?id=8809 It's still open, but the bug reporter noticed that it might be some interference with the login screen and plugins managed by LightDM. –  marcus Aug 9 '12 at 2:44
2  
You can try installing the package xfce4-battery-plugin. It contains a battery indicator that is independent of Xfce Power Manager. Too bad I can't add this as an answer. –  marcus Aug 10 '12 at 1:34
1  
I had this problem, i unchecked "Power Manager" from "Application Autostart" list in Settings -> Session and Startup and added another application with this command xfce4-power-manager --no-daemon then i have not have this problem yet. –  Saeed Zarinfam Sep 22 '12 at 17:12
1  
@SaeedZarinfam Can you post your comment as an answer so we can mark this question as solved? thanks! –  Jorge Castro Jul 6 '13 at 14:28
    
@JorgeCastro I did it. –  Saeed Zarinfam Jul 7 '13 at 7:29

1 Answer 1

I had this problem, i unchecked "Power Manager" from "Application Autostart" list in Settings -> Session and Startup and added another application with this command xfce4-power-manager --no-daemon then i have not have this problem yet.

share|improve this answer
    
Thanks, this solved a similar problem for me on Lubuntu 13.10. –  Duncan Feb 16 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.