Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am testing out 12.04 and am using Xinerama = 1 in xorg.conf.

When I do this, everything seems to work, except that some applications end up with strange looking buttons.

Please see this image: enter image description here Click here for an enlargement of the image.

As soon as I change the Xinerama to 0, I lose my quad screen, but all applications look normal again.

Why does this happen and is it possible to fix this?

I'm using gnome classic on Ubuntu 12.04 because I couldn't get Unity2D or Unity3D to work over 4 screens.

share|improve this question
    
You need to include some more details. ATI or Nvidia(or other). Model, etc. It's a good question, and I hope it gets a solid answer. We need details. –  hbdgaf May 1 '12 at 21:30
2  
Thanks, I've added further details. –  oshirowanen May 1 '12 at 21:43
    
Thank you. Since you noted Unity3d, my workaround doesn't work for you. It can be accomplished with Xinerama if don't need compositing/effects, but you have to want to give up 3d. I hope you get a proper answer. –  hbdgaf May 1 '12 at 21:47
    
To be honest, I don't mind giving up Unity3D and compositing/effects etc in order to get all 4 monitors working! –  oshirowanen May 1 '12 at 21:54
1  
Just to link your bug report for reference: bugs.launchpad.net/ubuntu/+bug/994835 –  desgua May 4 '12 at 23:22
show 9 more comments

closed as off topic by fossfreedom May 22 '12 at 18:26

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

It's a workaround for themes not applying in Cinammon with Xubuntu, but you could try: setting a GTK3 theme as default in XFCE configs, and, login again in Cinnamon from here.

Different problem, but it might work to get the theme to apply.

I don't know what DE you're using, but it's definitely not Unity.

share|improve this answer
    
I'm using gnome classic on Ubuntu 12.04 because I couldn't get Unity2D or Unity3D to work over 4 screens. –  oshirowanen May 11 '12 at 18:50
    
you should add that data to your question –  hbdgaf May 11 '12 at 18:53
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.