Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I upgraded my Ubuntu Server to 12.04 LTS today and now VSFTPD wont work. I think it is related to this VSFTPd stopped working after update.

However, unlike the asker in that post, I am not getting any error messages. When I log on, I get

220 (vsFTPd 2.3.5)
331 Please specify the password.
Password: 
530 Login incorrect.
ftp: Login failed

I know the password is correct,and I have tried multiple users. vsftpd.log shows nothing other than:

Tue May  1 15:19:48 2012 [pid 2] CONNECT: Client "192.168.1.133"
Tue May  1 15:19:53 2012 [pid 1] [USERNAME] FAIL LOGIN: Client "192.168.1.133"

Syslog shows nothing. Here is my VSFTPD.conf (mostly default):

listen=YES
anonymous_enable=NO
local_enable=YES
check_shell=NO
write_enable=YES
local_umask=022
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/private/vsftpd.pem

I tried the command mentioned in the previous question to no avail.

sudo chmod a-w /home/user

Thanks, I appreciate all your help!

share|improve this question

4 Answers 4

up vote 8 down vote accepted

In vsftpd.conf

Make the following change : pam_service_name=ftp

Save your change and restart the ftp server.

share|improve this answer
1  
Thanks! This worked! –  Austin May 15 '12 at 21:04
    
Thanks very much! You wouldn't believe how much of a pain this has been! –  Chris Edwards Dec 10 '12 at 14:00

Try to first login to the FTP through firefox or a browser, so you are sure to get a response why you are not able to log in.

This is just as a precausion to confirm if it is the login credentials itself or not.

share|improve this answer

Note: If running an amd64 kernel, you will need to add the following to your /etc/vsftpd/vsftpd.conf: seccomp_sandbox=NO

share|improve this answer

There are several Reason why you may get this reason.

Firewall-->>Tcp_wrapper-->>PAM-->>SElinux-->>FTPService-->> File.

  1. First Check if the given user is blocked or not in /etc/vsftpd/ftpusers /etc/vsftpd/user_list

  2. Check SElinux Context or Boolean for the Same.

  3. Check in PAM directory file. /etc/pam.d/vsftpd

auth required pam_shells.so

if user is not having required shell like in /etc/shells then it will give same error check getent passwd username match given shell with /etc/shells.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.