Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Windows XP inside VMware Player. I have two monitors and I keep VMware in fullscreen on the second monitor.

The problem is that if I work long enough in inside Windows XP, Ubuntu locks the screen as if I was idle. Once that happens I need to enter my password in order to return to the desktop on the other monitor.

Is there a way to fix or workaround this problem without disabling screensaver lock in Ubuntu temporarily or permanently?

share|improve this question
    
Did you ever find a solution to this. If so, could you please post it here - Thanks –  Vinodh Ramasubramanian Jan 3 '13 at 16:03
add comment

2 Answers

I think installing Caffeine could help you. It's a nice application which blocks your PC from going to suspend/lock-screen/black-screen when selected applications are running.

You can install it like this (available for precise):

sudo add-apt-repository ppa:caffeine-developers/ppa

sudo apt-get update

sudo apt-get install caffeine

After that just run the program. You will have a little indicator of a coffee mug in your panel.

active

inactive

You can manually activate Caffeine by clicking on the indicator and selecting "Deactivate screensaver" or you go to Preferences and select the applications for which it should activate itself automatically. It's also great for video players or Flash videos.

preferences

You can also read all about it here on OMG!ubuntu: http://www.omgubuntu.co.uk/2010/06/how-do-you-use-caffeine-the-app-not-the-stimulant/

share|improve this answer
    
While this is a good workaround that I was aware of it doesn't help the issue. It falls under "temporarily disabling locking" Still - upvoting because someone else might find it helpful. :) –  lightrush May 5 '12 at 17:49
add comment

Does this solve your problem anyway? For I could got only this far that I can only understand your problem as a screen locking problem not any other issues. https://help.ubuntu.com/11.10/ubuntu-help/session-screenlocks.html

share|improve this answer
    
Not really. As I mentioned disabling of lock screen or similar (extending the lock period) is not what I am looking for. However it seems that this might be cause by the Nouveau driver. I am still conducting investigation. :) –  lightrush May 5 '12 at 17:51
    
That link appears to be dead (404) but a 13.04 version exists at help.ubuntu.com/13.04/ubuntu-help/session-screenlocks.html –  djb Sep 9 '13 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.