Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu version is 10.10 and the laptop is Lenovo W520. A monitor is connected to the laptop through VGA. Display works under Window 7. But under Ubuntu, System->Preferences->Monitors only sees the laptop, not external monitor. How to switch and display on the external monitor? Thanks!

share|improve this question
    
Are you using a NVIDIA card? –  Javier Rivera May 2 '12 at 17:19

4 Answers 4

I used to use this.. I tried it now on 12.04 with Gnome Shell 3.4 and it worked. Just connect your external monitor, place it wherever you want (top, left, right..) and in terminal run this command:

xrandr --output VGA1 --primary

I hope it is what you're looking for.

share|improve this answer

Try to look for a hardware switch or function key on your laptop. The icon will usually look like a rectangle with two vertical line on the outside.

share|improve this answer

Two options are using the comand line disper tool, and using the graphical jupiter applet. There is also an indicator applet that has been built for disper.

The caveat I'd give for those is that they don't reliably work all the time for me.

Depending on your graphics card, you may be able to use a tool like nvidia-settings or settings for Catalyst/ATI.

Also see : How can I toggle between single and dual monitor setup?

share|improve this answer

I had the same problem with a (2007) Dell laptop with an Nvidia card. I already moved from the open source Nouveau drivers to nvidia-current propriety drivers for performance reasons, but Ubuntu (12.10) didn't recognize my external VGA monitor.

But after I switched to nvidia-current-updates it instantly displayed Ubuntu on my external monitor after reboot.

You can find this in Software Sources, if you have an ATI card you'll likely find something similar:

[since I have no reputation points I obviously cannot post an image!!]

share|improve this answer
    
Please upload the image and edit your answer to include the link. –  Eric Carvalho Nov 17 '13 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.