Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both Windows 7 and Ubuntu 12.04 installed on my Laptop. For some reason, windows had an error, so it started the repair tool. This was taking a while and so I cancelled it. Now my GRUB screen is gone, when I load up the computer it goes into an infinite reboot state. I can still access the BIOS and Windows 7 and Ubuntu 12.04 both still seem to be there (I am writing this from Ubuntu 11.10, which I have on a bootable DVD). Obviously the last resort is to remove everything and just use Ubuntu, but it would be much nicer to have them both fixed. Is there a way to re-install the GRUB screen or something?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can reinstall grub and that would fix the problem I guess. http://sosaysharis.wordpress.com/2011/06/29/recovering-grub-after-installing-windows-using-ubuntu/

share|improve this answer
    
When I run the 'fdisk' command, I get this output: 'Disk /dev/sda: 320.1 GB, 320072933376 bytes 255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0xbbcd25f4 –  JASAXBY May 1 '12 at 18:40
    
Device Boot Start End Blocks Id System /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT /dev/sda2 206848 237185023 118489088 7 HPFS/NTFS/exFAT /dev/sda3 237187070 588070911 175441921 f W95 Ext'd (LBA) /dev/sda4 588070912 625137663 18533376 27 Hidden NTFS WinRE /dev/sda5 237187072 439467132 101140030+ 7 HPFS/NTFS/exFAT /dev/sda6 439468032 581861375 71196672 83 Linux /dev/sda7 581863424 588070911 3103744 82 Linux swap / Solaris' –  JASAXBY May 1 '12 at 18:41
    
I'll assume that Linux is on '/dev/sda6/' and not '/dev/sda3/'. I know it should be kinda obvious from the labelling of the drives, but the fact that partition 3 is extended i making me wonder. –  JASAXBY May 1 '12 at 18:41
    
Why not try mounting them and see the files so that you can confirm which one is the Linux partition? :) –  harisibrahimkv May 1 '12 at 18:43
    
Ok, I think I've almost got this. It's just that when I run 'code'sudo grub-install _root-directory=/home/ubuntu/temp /dev/sda6'code' I get an error message saying 'More than one install devices?'. –  JASAXBY May 1 '12 at 18:54
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.