Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As of a few days ago I have this red circle with a horizontal white line through it persist on the panel in the top right. When I mouse over it, it says "A problem occurred when checking for the updates".

When there are updates to install, I can double click it and hit the 'install updates' button. There is a brief progress bar, and then nothing happens. I can right click the red circle and click 'insall all updates', and then it says its "marking" the updates à la synaptic package manager, and subsequently installs them.

The circle won't go away and it's just annoying. I'm not sure how it would be related, but since this started, I havn't been able to open ubuntu software centre. When I go applications> ubuntu software centre, my cursor just turns into the loading one for a few seconds, then nothing happens.

Any help is very appreciated.

Update: contents of /etc/apt/sources.list (without comments):

?deb http://au.archive.ubuntu.com/ubuntu/ maverick main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick main restricted

deb http://au.archive.ubuntu.com/ubuntu/ maverick-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick-updates main restricted

deb http://au.archive.ubuntu.com/ubuntu/ maverick universe
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick universe
deb http://au.archive.ubuntu.com/ubuntu/ maverick-updates universe
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick-updates universe

deb http://au.archive.ubuntu.com/ubuntu/ maverick multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick multiverse
deb http://au.archive.ubuntu.com/ubuntu/ maverick-updates multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ maverick-updates multiverse

deb http://archive.canonical.com/ubuntu maverick partner

deb http://extras.ubuntu.com/ubuntu maverick main
deb-src http://extras.ubuntu.com/ubuntu maverick main

deb http://security.ubuntu.com/ubuntu maverick-security main restricted
deb-src http://security.ubuntu.com/ubuntu maverick-security main restricted
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse
deb http://ppa.launchpad.net/wgrant/ppa/ubuntu maverick main
deb-src http://ppa.launchpad.net/wgrant/ppa/ubuntu maverick main

Update: contents of /var/log/apt/history.log:

Start-Date: 2010-11-01  11:15:47
Commandline: apt-get install gparted
Install: gparted:amd64 (0.6.2-1ubuntu1)
End-Date: 2010-11-01  11:16:04

Start-Date: 2010-11-01  23:46:57
Install: realpath:amd64 (1.15build1, automatic), clisp:amd64 (2.48-1.2), libffcall1:amd64 (1.10+cvs20100619-2, automatic), libsigsegv0:amd64 (2.5-3, automatic), libdb4.7:amd64 (4.7.25-9, automatic), common-lisp-controller:amd64 (7.2, automatic), cl-asdf:amd64 (1.704-1, automatic)
End-Date: 2010-11-01  23:47:18

Start-Date: 2010-11-01  23:47:53
Install: gambc:amd64 (4.2.8-1.1), libgambc4:amd64 (4.2.8-1.1, automatic), libgambc4-dev:amd64 (4.2.8-1.1, automatic), gambc-doc:amd64 (4.2.8-1.1, automatic)
End-Date: 2010-11-01  23:48:02

Start-Date: 2010-11-03  12:14:21
Upgrade: chromium-browser:amd64 (6.0.472.63~r59945-0ubuntu2, 7.0.517.41~r62167-0ubuntu0.10.10.1), gwibber-service:amd64 (2.32.0.1-0ubuntu1, 2.32.0.2-0ubuntu1), chromium-browser-inspector:amd64 (6.0.472.63~r59945-0ubuntu2, 7.0.517.41~r62167-0ubuntu0.10.10.1)
End-Date: 2010-11-03  12:14:38

Start-Date: 2010-11-04  11:18:21
Commandline: apt-get install flex
Install: m4:amd64 (1.4.14-3, automatic), flex:amd64 (2.5.35-9.1)
End-Date: 2010-11-04  11:18:29

Start-Date: 2010-11-04  11:18:39
Commandline: apt-get install bison
Install: bison:amd64 (2.4.1.dfsg-3)
End-Date: 2010-11-04  11:18:43

Start-Date: 2010-11-05  10:07:42
Upgrade: libpurple0:amd64 (2.7.3-1ubuntu3, 2.7.3-1ubuntu3.1), libcupsppdc1:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libpurple-bin:amd64 (2.7.3-1ubuntu3, 2.7.3-1ubuntu3.1), libcupsimage2:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), gvfs-fuse:amd64 (1.6.4-0ubuntu1, 1.6.4-0ubuntu1.1), libcupscgi1:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libcupsdriver1:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), ubufox:amd64 (0.9~rc2-0ubuntu5, 0.9~rc2-0ubuntu5.1), gvfs-backends:amd64 (1.6.4-0ubuntu1, 1.6.4-0ubuntu1.1), libasound2-dev:amd64 (1.0.23-1ubuntu2, 1.0.23-1ubuntu2.1), cups-client:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libfreetype6:amd64 (2.4.2-2, 2.4.2-2ubuntu0.1), cups-ppdc:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), lib32asound2:amd64 (1.0.23-1ubuntu2, 1.0.23-1ubuntu2.1), simple-scan:amd64 (2.32.0-0ubuntu3, 2.32.0-0ubuntu4), python-aptdaemon:amd64 (0.31+bzr506-0ubuntu2, 0.31+bzr506-0ubuntu4), cups-common:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libcups2:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), alsa-utils:amd64 (1.0.23-2ubuntu3, 1.0.23-2ubuntu3.4), aptdaemon:amd64 (0.31+bzr506-0ubuntu2, 0.31+bzr506-0ubuntu4), cups:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libasound2:amd64 (1.0.23-1ubuntu2, 1.0.23-1ubuntu2.1), flashplugin-installer:amd64 (10.1.85.3ubuntu1, 10.1.102.64ubuntu0.10.10.1), python-aptdaemon-gtk:amd64 (0.31+bzr506-0ubuntu2, 0.31+bzr506-0ubuntu4), libfreetype6-dev:amd64 (2.4.2-2, 2.4.2-2ubuntu0.1), xul-ext-ubufox:amd64 (0.9~rc2-0ubuntu5, 0.9~rc2-0ubuntu5.1), cups-bsd:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2), libgvfscommon0:amd64 (1.6.4-0ubuntu1, 1.6.4-0ubuntu1.1), gvfs:amd64 (1.6.4-0ubuntu1, 1.6.4-0ubuntu1.1), libcupsmime1:amd64 (1.4.4-6ubuntu2.1, 1.4.4-6ubuntu2.2)
End-Date: 2010-11-05  10:08:58

Start-Date: 2010-11-05  20:55:33
Commandline: apt-get install rdiff-backup
Install: python-pylibacl:amd64 (0.5.0-2, automatic), rdiff-backup:amd64 (1.2.8-5ubuntu2), librsync1:amd64 (0.9.7-7, automatic), python-pyxattr:amd64 (0.5.0-2, automatic)
End-Date: 2010-11-05  20:55:47

Start-Date: 2010-11-06  13:17:32
Remove: libswscale0:amd64 (0.6-2ubuntu6), libavutil50:amd64 (0.6-2ubuntu6), gstreamer0.10-fluendo-mp3:amd64 (0.10.14.debian-1), libboost-date-time1.42.0:amd64 (1.42.0-3ubuntu1), libavcodec52:amd64 (0.6-2ubuntu6), gstreamer0.10-ffmpeg:amd64 (0.10.11-1), gnash-common:amd64 (0.8.8-5ubuntu1), libgtkglext1:amd64 (1.2.0-1.1fakesync2), libboost-thread1.42.0:amd64 (1.42.0-3ubuntu1), libpostproc51:amd64 (0.6-2ubuntu6), libavformat52:amd64 (0.6-2ubuntu6), gnash:amd64 (0.8.8-5ubuntu1), libva1:amd64 (1.0.1-3), liboil0.3:amd64 (0.3.16-1ubuntu2)
End-Date: 2010-11-06  13:17:49

Start-Date: 2010-11-06  13:20:00
Remove: lib32bz2-1.0:amd64 (1.0.5-4ubuntu1), lib32ncurses5:amd64 (5.7+20100626-0ubuntu1), nspluginwrapper:amd64 (1.2.2-0ubuntu7), ia32-libs:amd64 (20090808ubuntu9), libc6-i386:amd64 (2.12.1-0ubuntu8), lib32gcc1:amd64 (4.5.1-7ubuntu2), lib32asound2:amd64 (1.0.23-1ubuntu2.1), flashplugin-installer:amd64 (10.1.102.64ubuntu0.10.10.1), lib32z1:amd64 (1.2.3.4.dfsg-3ubuntu1), lib32stdc++6:amd64 (4.5.1-7ubuntu2), lib32v4l-0:amd64 (0.6.4-1ubuntu1)
End-Date: 2010-11-06  13:20:09

Start-Date: 2010-11-08  15:46:39
Install: libswscale0:amd64 (0.6-2ubuntu6, automatic), libavutil50:amd64 (0.6-2ubuntu6, automatic), libavcodec52:amd64 (0.6-2ubuntu6, automatic), gstreamer0.10-ffmpeg:amd64 (0.10.11-1), libpostproc51:amd64 (0.6-2ubuntu6, automatic), libavformat52:amd64 (0.6-2ubuntu6, automatic), libva1:amd64 (1.0.1-3, automatic)
End-Date: 2010-11-08  15:46:52

Start-Date: 2010-11-09  16:23:09
Install: ubuntuone-client-gnome:amd64 (1.4.4.1-0ubuntu1)
End-Date: 2010-11-09  16:23:19

Start-Date: 2010-11-09  20:38:53
Install: python2.7:amd64 (2.7-6), python2.7-minimal:amd64 (2.7-6, automatic)
End-Date: 2010-11-09  20:39:03

Start-Date: 2010-11-10  09:26:09
Commandline: /usr/sbin/synaptic --dist-upgrade-mode --non-interactive --hide-main-window -o Synaptic::AskRelated=true
Upgrade: python-cupshelpers:amd64 (1.2.3+20100723-0ubuntu8, 1.2.3+20100723-0ubuntu8.1), sysvinit-utils:amd64 (2.87dsf-4ubuntu18, 2.87dsf-4ubuntu19), libsane-hpaio:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1), system-config-printer-gnome:amd64 (1.2.3+20100723-0ubuntu8, 1.2.3+20100723-0ubuntu8.1), hplip-cups:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1), hpijs:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1), hplip:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1), libhpmud0:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1), gdb:amd64 (7.2-1ubuntu2, 7.2-1ubuntu3), system-config-printer-udev:amd64 (1.2.3+20100723-0ubuntu8, 1.2.3+20100723-0ubuntu8.1), system-config-printer-common:amd64 (1.2.3+20100723-0ubuntu8, 1.2.3+20100723-0ubuntu8.1), sysv-rc:amd64 (2.87dsf-4ubuntu18, 2.87dsf-4ubuntu19), initscripts:amd64 (2.87dsf-4ubuntu18, 2.87dsf-4ubuntu19), hplip-data:amd64 (3.10.6-1ubuntu10, 3.10.6-1ubuntu10.1)
End-Date: 2010-11-10  09:26:52

Start-Date: 2010-11-10  18:39:25
Commandline: /usr/sbin/synaptic --dist-upgrade-mode --non-interactive --hide-main-window -o Synaptic::AskRelated=true
Upgrade: chromium-browser:amd64 (7.0.517.41~r62167-0ubuntu0.10.10.1, 7.0.517.44~r64615-0ubuntu0.10.10.1), chromium-browser-inspector:amd64 (7.0.517.41~r62167-0ubuntu0.10.10.1, 7.0.517.44~r64615-0ubuntu0.10.10.1)
End-Date: 2010-11-10  18:39:42

Start-Date: 2010-11-12  19:20:00
Commandline: /usr/sbin/synaptic --dist-upgrade-mode --non-interactive --hide-main-window -o Synaptic::AskRelated=true
Upgrade: libxml2-utils:amd64 (2.7.7.dfsg-4, 2.7.7.dfsg-4ubuntu0.1), xserver-xorg-video-intel:amd64 (2.12.0-1ubuntu5, 2.12.0-1ubuntu5.1), libvpx0:amd64 (0.9.2-1build1, 0.9.2-1ubuntu0.1), libxml2:amd64 (2.7.7.dfsg-4, 2.7.7.dfsg-4ubuntu0.1), python-libxml2:amd64 (2.7.7.dfsg-4, 2.7.7.dfsg-4ubuntu0.1)
End-Date: 2010-11-12  19:20:14

Start-Date: 2010-11-13  13:22:38
Commandline: apt-get install ssmtp
Install: ssmtp:amd64 (2.64-4fakesync1)
End-Date: 2010-11-13  13:22:45

Start-Date: 2010-11-13  13:40:07
Commandline: apt-get install mutt
Install: mutt:amd64 (1.5.20-9ubuntu2)
End-Date: 2010-11-13  13:40:13
share|improve this question

3 Answers 3

up vote 1 down vote accepted

It looks like you're not using maverick's normal system Python (since the CommandNotFound module has apparently gone missing). Have you installed Python from source? If so, try sudo ln -sf python2.6 /usr/bin/python, and sudo apt-get update again.

share|improve this answer

Opening a terminal and sudo rm /var/cache/apt/*.bin then sudo apt-get update && sudo apt-get upgrade should solve the issue.

share|improve this answer
    
I did that and restarted, but the problem persists :( –  oadams Nov 13 '10 at 1:43
    
Have you added any repositories or PPAs to your sources.list? Can you please post the contents of the file /etc/apt/sources.list? –  ryanklee Nov 13 '10 at 1:53
    
Done, I added it to the OP because it wouldn't fit in the comments box. Yes, I added someone's launchpad PPA a while back. –  oadams Nov 13 '10 at 2:15
    
OK, well, you sources.list looks kosher, basically. The only thing that looks suspect (but doesn't actually look suspect really) is the launchpad ppa. Why don't you go ahead and comment it out and apt-update/upgrade while I look around and try to figure out what is going on (just in case that's the issue, but if you don't feel comfortable doing that, then just sit tight and I'll try to see what the problem is in any case). –  ryanklee Nov 13 '10 at 2:34
    
I commented out those two lines, and did the apt-update and upgrade, but the problem is still there. –  oadams Nov 13 '10 at 3:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.