Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I log into a desktop environment, it doesn't seem that compositing is starting. Unity 2D works fine, but when I go to Unity 3D Compiz doesn't start up. I have to type compiz --replace & in terminal every time I login. Another example is when I log into a Cinnamon session, theming support is suddenly gone (although this may be a separate issue). If it helps im using the latest (295.40) NVIDIA drivers.

EDIT: I am having exactly the same issue in both cases, upgrading from 11.10 and with a clean installation, in 32 and 64 bits.

Related post.

share|improve this question

Many people seem to have the same problem.

You will need to delete the compiz and compiz-1 directories in your home .config directory.

Compiz files are then re-generated when you re-boot and log in again.

It worked for me.

share|improve this answer
"/ i tried this but compiz is still not starting up. – nerdondon May 2 '12 at 20:05

sudoedit /usr/share/gnome-session/sessions/ubuntu.session

try to check if everything is ok there (it opens you session config file). There should be this line:


Also make sure that your computer is supporting everything 3D mode needs. For more info look here

share|improve this answer

The 'logical' answer would be to add compiz --replace to the startup programs. I had to answer for the people trying this that this not only didn't work for me, but it made unity not to start at all. I'm still looking for the answer as I need compiz working perfectly fine on startup.

share|improve this answer
I'm totally aware that I can just add that to startup applications, but my issue is that I want to use cinnamon and the upgrade just borked that installation. Cinnamon doesn't use compiz for compositing/window management. – nerdondon Jun 27 '12 at 9:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.