Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I install Eclipse from the Software Center so it links up and will be updated with the rest of my software. Because I am developing for Android, however, I have to install the ADT Plugin within Eclipse by going to Help > Install new software (or something to that effect). Now, I do understand that I can update Eclipse through the actual Ubuntu software center/system, but in order to update plugins and extensions within Eclipse, I have to go to Help > Check for Updates (which then scans all plugins for updates). The only issue, is that when I installed through the software center, the owner became root, and whenever I run it without root, I'm not able to update - I get the error message "Insufficient access privileges to apply this update." When I run it as root, all of my plugins disappear, because I guess I installed them as myself, not as root. I tried to install the plugins as root, but the Install New Software choice would not work.

Ubuntu 12.04 and Eclipse 3.7.2-1

share|improve this question
    
I just tried uninstalling Eclipse and then reinstalling it, running it as root first to have the plugins associated with the root account, so I could update them from there. Unfortunately, when I installed the plugins, they didn't take. They didn't show up when I ran using root, or just as a regular user. Therefore, I couldn't access them or update them! –  Nicholas Ryan Bowers May 2 '12 at 0:30

2 Answers 2

up vote 5 down vote accepted

The best solution is to become root using su or by logging in as the root user from the start, if you have that ability (Ubuntu users don't, unless they fixed that defect). Anyhow, once you are root, do a chown -R user:group to the path for your eclipse installation.

Then your regular user should be able to install plugins. In the future, do not install eclipse as the root user. Root can still use eclipse when another user installs it and owns it.

share|improve this answer
1  
as mentioned by gary chown -R user:group to yourself at /usr/lib/eclipse if you installed eclipse via synaptic it uses root :( –  peterretief Oct 2 '12 at 13:56
    
I doesn't work, I get "Could not open the editor: No editor descriptor for id org.eclipse.jdt.ui.CompilationUnitEditor". –  BornToCode Nov 13 '13 at 3:16
    
If your username is foo, your group name is bar and your eclipse installed path is /usr/lib/eclipse this should work for you: sudo chown -R foo:bar /usr/lib/eclipse –  Farahmand Feb 10 at 16:08

Finally fixed the issue by completely uninstalling Eclipse using Synaptic, and then reinstalling. Once reinstalled, I opened it up as root to update the platform and other upgrade-able software. I then closed it and opened it up as a normal user to install the ADT Plugin. This way, the plugin shows during normal sessions, and can be updated in normal sessions, and if I want to update another component of the Eclipse system, I can launch it as root.

share|improve this answer
    
so basically you followed the directions here: askubuntu.com/questions/124963/… ? –  hbdgaf May 4 '12 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.