Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bug where my CPU frequency is scaling down every few hours or so. This happens when:

  1. I'm on AC power
  2. scaling governor is on 'Performance'

What do you have to do to disable CPU frequency scaling? I know you can manually force the min CPU frequency uder /sys/devices/system/cpu, however I really want a permanent solution so I don't have to be constantly changing the CPUfreq values.

share|improve this question
    
It's normal that your CPU's frequency goes down every once in a while even on AC power, as actual CPU loads vary over time. Normally it is best to leave cpu frequency untouched, but you can always change it permanently by following ayan4m1's advice. –  Mathieu Trudel-Lapierre Nov 13 '10 at 0:21

2 Answers 2

Just to make sure it's not going to interfere, remove the powernowd package from your system. From a terminal, run:

sudo apt-get remove powernowd

After that, or if you don't have that package installed, install rcconf by running:

sudo apt-get install rcconf

Then run sudo rcconf and press space with the ondemand service highlighted to disable it. This service controls CPU frequency scaling. Press enter to save and quit. To manually stop it once, you can run sudo /etc/init.d/ondemand stop.

share|improve this answer
    
You can also set a specific cpu frequency governor by changing that script and setting the governor to say, "performance" or "conservative" rather than "ondemand". –  Mathieu Trudel-Lapierre Nov 13 '10 at 0:22

I guess ayan4m1 explain everything to remove cpu frequency scaling from your box, except by one little detail: If you remove cpu scaling (or set it for performance service), then you will increase energy consumption (even in AC power).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.