Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When attaching a USB flash disk (NTFS formatted) to a laptop with Ubuntu Server 12.04 on board, I get following messages:

[ 3572.355603] sd 2:0:0:0: [sdb] No Caching mode page present
[ 3572.355640] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 3572.361599] sd 2:0:0:0: [sdb] No Caching mode page present
[ 3572.361636] sd 2:0:0:0: [sdb] Assuming drive cache: write through

I get them right in the terminal, so that I should press Ctrl+C to proceed with working (entering commands).
Is it normal or do I have to setup Caching mode somehow?
Thank you.

share|improve this question

1 Answer 1

Seems like the write cache is enabled for all devices you plug into the laptop or the /etc/fstab file has the option async. Something like:

[...]
/dev/sdb1    /media/USB    auto        async    0   0
/dev/sdb1    /media/USB    auto        default    0   0
[...]

(Note: default option is the same as rw, suid, dev, exec, auto, nouser, and async

or activated in hdparm:

sudo /sbin/hdparm -I /dev/sdb

/dev/sdb:
[...]
Commands/features:
    Enabled Supported:
       *    SMART feature set
       *    Power Management feature set
       *    Write cache <-------
       *    Look-ahead
       *    WRITE_VERIFY command
[...]
Checksum: correct

This is the default option. So, it seems that your USB don't support this caracteristic which triggers the strout warning. You can disable it replacing the lines in fstab or issuing sudo hdparm -W 0 /dev/sdb.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.