Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ive fresh installed ubuntu 12.04 and wanted to look for updates. An error occurred and asked if i want to repair dependencies. So I did what it asked for but it failed again and again and again. Same thing happens when i want to install software from repositories "sudo apt-get install ...". Ive read that it can be solved by installing missing dependencies by "sudo apt-get install -f". But it failed with error again:

Errors were encountered while processing:
 /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions what to do?

sudo dpkg --configure -a

gave me:

Errors were encountered while processing:
 libqtgui4:i386
 libqt4-sql:i386
 ia32-libs-multiarch:i386
 libqt4-declarative:i386
 libqt4-svg:i386
 libqt4-network:i386
 libqt4-sql-mysql:i386
 libqt4-script:i386
 libqt4-dbus:i386
 ia32-libs
 libqt4-opengl:i386
 libqtwebkit4:i386
 libqt4-designer:i386
 libqt4-scripttools:i386
 libqt4-qt3support:i386
 libqt4-xml:i386
 libqt4-test:i386
 libqt4-xmlpatterns:i386

Ive done:

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f

still getting this error:

Errors were encountered while processing:
 /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
    
Have you used any PPAs? –  lightrush May 1 '12 at 14:42
    
try this: sudo dpkg --configure -a –  Shaneo1 May 1 '12 at 14:48
add comment

1 Answer

up vote 1 down vote accepted

Clean your cache and redownload the packages sudo apt-get clean sudo apt-get autoclean, then try with sudo apt-get install -f , I've been getting these errors too.

share|improve this answer
    
Still getting same error. (updated my first post) –  Luky May 1 '12 at 15:14
    
Open nautilus with root permissions gksu nautilus navigate to the folder and delete the file then try again, and try with a different mirror. –  Uri Herrera May 1 '12 at 15:18
    
How can i choose different mirror? –  Luky May 1 '12 at 15:31
    
Open software properties software-properties-gtk –  Uri Herrera May 1 '12 at 16:31
    
Ive changed the mirror to one of recommended locals and updated all i found. It looks great :) Ty for your advices. –  Luky May 2 '12 at 12:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.