Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ive fresh installed ubuntu 12.04 and wanted to look for updates. An error occurred and asked if i want to repair dependencies. So I did what it asked for but it failed again and again and again. Same thing happens when i want to install software from repositories "sudo apt-get install ...". Ive read that it can be solved by installing missing dependencies by "sudo apt-get install -f". But it failed with error again:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions what to do?

sudo dpkg --configure -a

gave me:

Errors were encountered while processing:

Ive done:

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f

still getting this error:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
Have you used any PPAs? – Nicolay Doytchev May 1 '12 at 14:42
try this: sudo dpkg --configure -a – Shaneo1 May 1 '12 at 14:48
up vote 1 down vote accepted

Clean your cache and redownload the packages sudo apt-get clean sudo apt-get autoclean, then try with sudo apt-get install -f , I've been getting these errors too.

share|improve this answer
Still getting same error. (updated my first post) – Lukas Vilim May 1 '12 at 15:14
Open nautilus with root permissions gksu nautilus navigate to the folder and delete the file then try again, and try with a different mirror. – Uri Herrera May 1 '12 at 15:18
How can i choose different mirror? – Lukas Vilim May 1 '12 at 15:31
Open software properties software-properties-gtk – Uri Herrera May 1 '12 at 16:31
Ive changed the mirror to one of recommended locals and updated all i found. It looks great :) Ty for your advices. – Lukas Vilim May 2 '12 at 12:28

Same here but with also the following output:

The following packages have unmet dependencies:
mysql-community-server : Depends: mysql-common (= 5.7.10-1ubuntu14.04) but 5.7.11-1ubuntu14.04 is to be installed
                      Depends: mysql-client (= 5.7.10-1ubuntu14.04)
mysql-server : Depends: mysql-community-server (= 5.7.11-1ubuntu14.04) but 5.7.10-1ubuntu14.04 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The solution for me was:

sudo apt-get install -f mysql-community-server
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.