Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I add customized wallpapers so they appear in the dynamic unity greeter?

LightDM only changes wallpapers if I have selected one of the default wallpapers. If I choose another image from my pictures, LightDM shows the default wallpaper.

Why is this happening, and how can I make LightDM show my wallpaper if it is not one of the defaults?

As @doug said in his answer, it works if you click on the little + symbol in the appearance settings: after you do that, LightDM changes wallpapers.

share|improve this question

marked as duplicate by Marco Ceppi Sep 6 '12 at 14:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
I think this is a duplicate guys, you'll find your answer here –  Insperatus Sep 6 '12 at 9:51
add comment

6 Answers 6

I bet you use an encrypted home folder - which is readable not before you log in. What you can do is to copy your background image for instance to /usr/share/backgrounds (as root, i.e.: sudo cp ~/Pictures/backgroundimage.png /usr/share/backgrounds/) and set it as background image out of this un-encrypted folder.

share|improve this answer
    
Thanks. It worked. although my /home is not encrypted, I was facing the same issue. –  Ubuntuser Jun 5 '12 at 8:58
    
Oh, thanks! Than it is not a problem of encryption. –  Jakob Jun 5 '12 at 15:51
add comment

Not sure what the problem in LightDM really is but i solved this by scaling my wallpaper to my screens resolution. I moved them to /usr/share/backgrounds (location of the default wallpapers) as well. Not sure what did the trick but it works for me.

share|improve this answer
    
But the problem is that LightDM has to do this automatically, not manually. And in the alpha version this was fine –  Mauricio May 1 '12 at 14:49
1  
I'm with you about that so i filed a bug report: bugs.launchpad.net/ubuntu/+source/lightdm/+bug/992646 –  sulaweyo May 1 '12 at 14:56
add comment

Still works fine here, either from ~/Pictures, added from the dropdown or any other location, added from the little + under the wallpapers in Appearance window

The directory holding your chosen Background image must allow Others execute permission so maybe check the permissions of the folder holding your image

Ex. of the min necessary permissions

$ ls -ld Pictures
drwxr-xr-x 2 doug doug 4096 Apr 30 00:02 Pictures
share|improve this answer
    
How I give that permissons? (My ubuntu is ins spanish so i thing that changes the command) –  Mauricio May 1 '12 at 15:35
    
This is what I get drwxr-xr-x 7 mauricio mauricio 4096 abr 30 22:03 Imágenes –  Mauricio May 1 '12 at 15:54
add comment

I can confirm that it's not a matter of "+" button. You can either use a cp command, a "+" or Nautilus. It will not work UNTIL you resize the image to your screen resolution.

Now it works!

Thank to all.

^Pepe^

share|improve this answer
    
Sure you are talking about the login screen (LightDM) and not about the boot screen (GRUB)? –  Jakob May 5 '12 at 8:20
add comment

You don't even need to copy the picture in /usr/share/backgrounds folder. You just need to use full path to the image. I've tested that and working.

  1. Go to This answer to get help on changing lightdm wallpaper.

  2. Follow all the commands begining from sudo -i to disable user background

  3. Before the last command which sets the background image, Do this command

    export $(dbus-launch)
    

    It will say, no protocol specified but ignore those warning.

  4. In the last command where you are going to change the wallpaper, use full path. For example, I used this command to set a picture in my home directory

    gsettings set com.canonical.unity-greeter background '/home/anwar/Below_Clouds_by_kobinho.jpg' 
    

Please note: Make sure to use ' mark in the start and end of location.

That's it. Logout to see your image.

share|improve this answer
add comment

If your desktop wallpaper is in some other partition than the root, then it won't show up. The reason being that other partitions don't automatically get mounted, you mount them after you log in.

I think copying the wallpaper in Pictures or Home directory should help.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.