Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

2 days ago I've upgraded my ubuntu to 12.04. It's running dual boot with windows 7 on an acer aspire 8930 which has a intel wifi link 5100.

I now have wifi problems where it constantly switches on and off and has e really weak signal.

Could anybody help.

share|improve this question

1 Answer 1

The Intel WIreless with the Linux Kernel has always not worked well. This is the workaround to get it to work properly:

  1. Press Ctrl + Alt + T. Type in this command: sudo gedit /etc/modprobe.d/intel_11n_disable.conf
  2. Paste this into the gedit windw that opens: options iwlagn 11n_disable=1
  3. Save, and close gedit. When back at the prompt type sudo update-initramfs -u.
  4. Run sudo modprobe -r iwlagn && sudo modprobe iwlagn.
  5. Try it out!

Hope that helps! Source: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/871254

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.