Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my newly-installed Ubuntu 12.04 LTS, my ZTE K3805-Z Vodafone-branded USB 3G dongle shows in the notification area as a 'Mobile Broadband' connection called 'Vodafone Contract'. So far, so good!

...BUT I cannot access the Internet. I receive the error 'Problem loading page - server not found'. Firefox works with a wired connection and the dongle works under Windows Vista (which I detest!). If someone out there can fix this, I promise to delete Windows Vista!

share|improve this question
    
I am not getting even 60 kbps speed from Vodafone and it disconnecting every 2 minutes. I am using HUAWEI 303C data card with Vodafone connection. I switch over to docomo and it is working fine for me, getting 1 - 3 Mbps speed. Better to go for Airtel or Tata DOCOMO. –  user74084 Jun 29 '12 at 18:53
add comment

4 Answers 4

Open up a terminal from Applications -> Accessories. Type:

sudo gedit /etc/modules

At the bottom of the file, make two new lines, like this:

usbserial
option

Then close the editor program and save it. Reboot the computer and hopefully you’ll be right from now on!

share|improve this answer
add comment

I also had problem with my huaway e173 3g modem. It was restarting and not conecting to the network. However I found a solution. When I was configuring my mobile broadband connection, the system found my usb dongle as "huaway e173", but with this setting was restarting. So I tried selecting "any GSM device" and now my 3g is working. All other setting are default as found by the manager.

share|improve this answer
add comment

Did you enter the username and password when you created the connection? In the option to edit VODAFONE CONNECT you will find a tab called MOBILE BROADBAND where you have to put the username and password.

You can get the details of it by googling for it or from Vodafone Customer Care. Or if that dongle uses an application in windows,in that application too, in settings you will find those details entered.

share|improve this answer
add comment

I had the same issue and here is what worked for me:

Vodafone 3g pen k3805-z requires sudo ifconfig usb0 -arp prior to connecting to achieve connectivity. It appears as if everything is blocked unless arp is disabled.

See this bug report for more clarity: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/764003

share|improve this answer
add comment

protected by Community Jul 4 '12 at 10:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.