Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm sure this question has been asked before, but I can't seem to locate it on this website, so here goes.

My gnome3 does not look like it should. When I first installed gnome-shell, it worked, but after rebooting once, the interface looks like the classic gnome interface.

Example screenshot

I'm looking for an answer to why this behavior exists and how to fix it.

Note that I had this problem before, and I was able to (accidentally) get it to work in Ubuntu 11.10, so it's not likely to be a hardware error.

I'm running Ubuntu 12.04 32-bit on a HP Pavilion dv6. My Settings > Details > Graphics reads "driver: unknown, environment: fallback"

Result of gnome-shell --replace That does display the gnome3 bar at the top, along with the Super key functionality, but the windows go all flashy and it's hard to navigate between windows. This is the output in the terminal.

gnome-shell --replace
Agent registration failed: Already Exists
Warning of window manager:Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Waarschuwing van vensterbeheer:Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)

(gnome-shell:4549): folks-WARNING **: Failed to find primary PersonaStore with type ID 'eds' and ID 'system'.
Individuals will not be linked properly and creating new links between Personas will not work.
The configured primary PersonaStore's backend may not be installed. If you are unsure, check with your distribution.
share|improve this question
    
what does gnome-shell --replace give you? try logging out and logging into GNOME section (can be chosen from clicking the little icon) –  vanlong441 May 1 '12 at 10:56
    
That seems to be a step in the right direction, see edited post. –  Honoki May 1 '12 at 11:12
    
I think u missing some drivers which block Gnome-shell from loading.I dont know you tried "additional driver" option or not. –  beeju May 2 '12 at 10:30
    
I did try the additional drivers (fglrx), but they either cause my system to boot in low graphics mode, or they change nothing at all. –  Honoki May 2 '12 at 10:56
    
ATI fglrx is not working properly in GNOME Shell. My current advice is to go with Unity or download and install this OS instead. It's basically Ubuntu 12.04 with GNOME Shell preinstalled. webupd8.org/2012/04/… –  vanlong441 May 10 '12 at 4:06

2 Answers 2

Got the same error after last apt-get upgrade. But with gnome-shell --replace it actually started even if it confirmed error.

If you're using the prohibited driver for your fglrx card. One solution can be to Download the amd-driver-installer-12-4-x86.x86_64.run from AMD, using these commands:

wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-4-x86.x86_64.run
sh amd-driver-installer-12-4-x86.x86_64.run --extract
cd fglrx-install.NDh3QS/common/lib/modules/fglrx/build_mod
vim fglrx.patch

and add:

fixed fgrlx compilation error on 32-bit x86 arch with kernel 3.3-rc4 due to commit:
https://github.com/torvalds/linux/commit/f94edacf998516ac9d849f7bc6949a703977a7f3
later modified (in 3.3-rc5) by commit:
https://github.com/torvalds/linux/commit/7e16838d94b566a17b65231073d179bc04d590c8#diff-1
and finally backported to kernel 3.2.8.

This new version adds support for the 3.4 kernels, where some ASM header
file was splitted into several smaller files, so we have to explicitally
include the new file <asm/fpu-internal.h>.

Since 3.4-rc2, cpu_possible_map has been definitely removed. Let's use
cpu_possible_mask instead. This is probably required also for 64 bit kernels.

Signed-off-by: Gianluca Gennari <gennarone@gmail.com>
---
 firegl_public.c |   13 +++++++++++++
 1 files changed, 13 insertions(+), 0 deletions(-)

diff --git a/firegl_public.c b/firegl_public.c
index a56fff1..b4bdfb7 100644
--- a/firegl_public.c
+++ b/firegl_public.c
@@ -187,6 +187,9 @@
 #include <linux/gfp.h>
 #include <linux/swap.h>
 #include "asm/i387.h"
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,4,0)
+#include <asm/fpu-internal.h>
+#endif

 #include "firegl_public.h"
 #include "kcl_osconfig.h"
@@ -4181,7 +4184,11 @@ static int kasInitExecutionLevels(unsigned long level_init)
 {
     unsigned int p;
     KCL_DEBUG5(FN_FIREGL_KAS, "%d\n", level_init);
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,4,0)
+    for_each_cpu_mask(p, cpu_possible_mask)
+#else
     for_each_cpu_mask(p, cpu_possible_map)
+#endif
     {
         KCL_DEBUG1(FN_FIREGL_KAS,"Setting initial execution level for CPU # %d\n", p);
         preempt_disable();
@@ -5799,10 +5806,16 @@ void ATI_API_CALL KCL_fpu_begin(void)
 #ifdef CONFIG_X86_64
     kernel_fpu_begin();
 #else
+#ifndef TS_USEDFPU
+    preempt_disable();
+    if (__thread_has_fpu(current))
+        __save_init_fpu(current);
+#else
     struct thread_info *cur_task = current_thread_info();
     preempt_disable();
     if (cur_task->status & TS_USEDFPU)
         __save_init_fpu(cur_task->task);
+#endif
     else
         clts();
 #endif
-- 
1.7.5.4

Then execute

patch -p1 < fglrx.patch
cd ../../../../
./ati-installer.sh 8.961 --buildpkg Ubuntu/precise
cd.. 
sudo dpkg -i *.deb
aticonfig --initial

Now the kernel module is located at /usr/src/fglrx-8.961 and it's now easier to just reinstall (add future patches) with sudo dkms "remove/build/install" fglrx/8.961, read man pages for dkms if you need additional information.

share|improve this answer

I'm running Ubuntu 12.04 32-bit on a HP Pavilion dv6. My Settings > Details > Graphics reads "driver: unknown, environment: fallback"

"enviroment: fallback" means that you are running so-called gnome-session-fallback which is actually designed to look as gnome 2. Try to log out and change session (can be changed via small round button above login bar) should work.

share|improve this answer
    
The selection of the session is not the problem. When choosing gnome3, it falls back from the moment I'm logged in. I've tried plenty of tricks (often resulting in having to reset things from the command line at startup), but none seemed to work. I've given up for now, and sticking with Unity. –  Honoki Jun 16 '12 at 23:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.