Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying out the new MAAS tool on my laptop and have installed the MAAS server in a VirtualBox VM. Since the PXE boot option is not working for me in a virtualized enviornment I tried to install a node with the CD-ROM option instead.

I select the option "Multiple server install with MAAS" then it proceeds up to the option of entering the IP address of the MAAS server. I have MAAS already installed on another VM and provide the IP address of the MAAS server.

The problem is that immediately after the node shuts down without completing the install process. I tried to look in the MAAS server and the node is not registered there either. Any ideas?

share|improve this question
    
Can you reach the MAAS server IP from your client? –  Javier Rivera May 2 '12 at 6:57
    
What versions or Virtualbox, pxeboot, and OS are you running as your host OS? There was a known bug with PXE that got fixed a while back(involved a bunch of variables. suffice it to say it's fixed)? Also, are you using a NAT adapter for the network or bridged with a thin software router. In the latter case it's easier to get PXE working in the virtual environment. –  hbdgaf May 21 '12 at 22:33
add comment

3 Answers

I deployed both physical servers (successfully) and on VirtualBox (failing). The immediate shut down is the intended behavior. The problem with VirtualBox is that, once the installation process of the server is complete, the server should be able to wake-on-lan (optional), and PXE boot (required). I haven't figured out how to PXE boot in VirtualBox, unfortunately. Anyway, your failure is not in the installation process. It's the PXE booting.

share|improve this answer
add comment

You should have a look at Testing MAAS on edubuntu wiki, which gives instructions to test MAAS in virtual machines. There are some hints regarding PXE boot but with virt-manager instead of VirtualBox. It may help!

share|improve this answer
    
By the way, it looks like your question is linked to MaaS Enlistment through 12.04 installation CD fails –  maximd May 17 '12 at 23:00
add comment

I have used

ethernet0.virtualDev = "vlance"

setting.

And at router edit

/etc/dnsmasq/dhcp.conf

add

dhcp-boot={pxeboot file}, {hostname of tftp server}, {ip address of tftpserver}

(dhcp-boot=10.10.10.50 - in my case)

then

/etc/init.d/dnsmasq restart

Voila!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.