Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently upgraded to precise and whenever I try and login using the default "Gnome" or "Unity" options, I'm presented with either Gnome Classic or Unity 2d (confirmed by $DESKTOP_SESSION).

My graphics card is an ATI Radeon HD 5450 so I feel like it should quite happily run 3d. I've upgraded my version of ATI Catalyst to the proprietary 12.4 drivers and it hasn't done anything.

Any help would be appreciated!

share|improve this question
    
Is your graphics card compatable for Unity 3D. Try Unity 2D and see if it works. –  JDL May 11 '12 at 9:20

1 Answer 1

I had the same problem myself just the other day. I fixed it by running this:

sudo apt-get install libglade2-dev libglade2.0-cil libglade2.0-cil-dev libglib2.0-cil-dev libgtk2.0-cil-dev libxml2-dev libdrm-intel1 xserver-xorg-video-intel

Also, I removed these packages using Synaptic:

xserver-xorg-video-ati
xserver-xorg-video-radeon
nvidia-current
nvidia-current
libgl1-mesa-dri:i386
nvidia-settings
xserver-xorg-video-nouveau 

All works great. From what I have read the real problem lies in the nouveau drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.