Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded mythbuntu 11.10 to mythbuntu 12.04. I had a working MCE usb remote suspend/wakeup thing going for me. After the upgrade wake on usb does not work. The light on the usb ir-receiver does not flash either when trying to wake up. The computer resumes well with the power button.

I have the following in my /etc/rc.local:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

sudo sh -c "echo USB0 > /proc/acpi/wakeup"
sudo sh -c "echo USB1 > /proc/acpi/wakeup"
sudo sh -c "echo USB2 > /proc/acpi/wakeup"
sudo sh -c "echo USB3 > /proc/acpi/wakeup"
sudo sh -c "echo enabled > /sys/bus/usb/devices/3-1/power/wakeup"

exit 0

lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
Bus 003 Device 003: ID 195d:7777 Itron Technology iONE Scorpius wireless keyboard

cat /proc/acpi/wakeup

Device  S-state   Status   Sysfs node
P0P1      S4    *disabled  pci:0000:00:1e.0
P0P4      S4    *disabled  pci:0000:00:1c.0
P0P5      S4    *disabled  pci:0000:00:1c.1
P0P6      S4    *disabled  pci:0000:00:1c.2
P0P7      S4    *disabled  
P0P8      S4    *disabled  
P0P9      S4    *disabled  
USB0      S3    *enabled   pci:0000:00:1d.0
USB1      S3    *enabled   pci:0000:00:1d.1
USB2      S3    *enabled   pci:0000:00:1d.2
USB3      S3    *enabled   pci:0000:00:1d.3
EUSB      S3    *enabled   pci:0000:00:1d.7

I have a similar problem with identical hardware on an Ubuntu install. After the upgrade on that, wake on usb keyboard doesn't work.

What I don't get is why it worked before the upgrade? What has changed?

share|improve this question
    
I dont know how you got 12.10. funny eh?(Little excited i know)Suspend/Hibernation is disabled on 12.04 by default. Pls read this wiki.ubuntu.com/PrecisePangolin/ReleaseNotes/UbuntuDesktop –  beeju May 1 '12 at 7:53
    
;) yeah 12.04. But the wiki does not answer my question. I don't have problems suspending, hibernating on waking my computers up. The problem is waking it up using my remote or keyboard! –  user59035 May 1 '12 at 12:57
add comment

marked as duplicate by aquaherd, Radu Rădeanu, Eric Carvalho, Thomas W., user68186 May 31 '13 at 1:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 0 down vote accepted

Got it to work.

I created a new rule:

sudo gedit /etc/udev/rules.d/90-mcewakeup.rules

Entered this in with the correct product and vendor id's (with the help of lsusb):

SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

Edited one line in my grub (added "usbcore.autosuspend=-1 acpi_enforce_resources=lax"):

sudo gedit /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"

After which:

sudo update-grub

After a reboot tested it and it worked.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.