Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did something silly I think.

I wanted to use dolphin as default file manager. So I used package manager (synaptic) to remove nautilus file manager (because Ubuntu makes it so hard to change the default file manager globally).

Now when I rebooted and wanted to login, I no longer see the Ubuntu unity desktop as an option to select from the menu at the login prompt. I only get into the gnome classical and gnome options.

I went back to package manager and reinstalled nautilus file manager, and rebooted, but still, when I get to login in screen, I do not see the unity desktop (no 2D option, nothing) it only shows 2 options, gnome and gnome classic. I tried both, but they are not the same as the original desktop I had which is unity, with the launcher on the left, and the dash thing, and the 4 desktops, etc...

(so confusing, so many desktops, and not even a way to find which desktop one is on at the time. Like right-click with the mouse on the desktop, should tell one, "you are using GNOME(classic)" or something.

Anyway, What do I need to do to get unity desktop? Do I need to reinstall 12.04? How? I am already on 12.04. I do not want to lose all the configurations I did.

share|improve this question

1 Answer 1

up vote 11 down vote accepted

Reinstall unity.

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
share|improve this answer
    
brilliant! that worked. +100 thanks! –  Nasser May 1 '12 at 6:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.