Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my ubuntu karmic to lucid a few months ago. I don't know when it all started but the thing is that when I log in, I see a very intense disk access activity for a while that prevents any application from starting in a reasonable time (it takes from 10 to 20 seconds).

That's why I cannot launch a terminal window and top or iostat just in time to see what happens. When it prompts it's too late.

I tried to delimit the problem uninstalling zeitgeist, docky or whatever program I thought was behind that behaviour. I even deleted my Private encrypted folder to avoid decryption issues. Nothing changed.

Any idea about how to proceed? Thanks in advance.

share|improve this question

1 Answer 1

up vote 8 down vote accepted

I'd switch to a virtual terminal at the GDM login screen (Ctrl+Alt+F1), log in and start iotop (you maybe need to install it first). Then switch back to GDM (Ctrl+Alt+F7), log in, and immediately switch back to iotop using Ctrl+Alt+F1. You should now see, which process is responsible for the heavy IO.


Forgot to mention an alternative: you could try using bootchart to generate a chart that visualizes the boot process + desktop start. You maybe need to edit its configuration, so it shows more than just the first seconds of desktop loading:

Open the file '/etc/init/bootchart.conf' and remove the line:

--crop-after=compiz,metacity,mutter,kwin,xfwm4 \

Two things:

  1. You maybe need to reboot twice after the first installation to get a useful result (it's possible that an index file needs to be rebuilt, I don't know for sure).

  2. Once installed, bootchart will run on every boot, unless you add bootchart=disable to the 'GRUB_CMDLINE_LINUX_DEFAULT' parameter in '/etc/default/grub' (followed by a sudo update-grub).

share|improve this answer
    
good solution... –  hbdgaf Nov 12 '10 at 18:54
1  
Perhaps it's Ubuntu One indexing files? U1 still trashes my system even on Maverick. –  Leon Nardella Nov 12 '10 at 20:00
    
Never had an issue with U1, but I often see apt-xapian-index hosing my system for a minute or so on slower hardware. You'd see that hitting your CPU though (top or htop). More here : bugs.launchpad.net/ubuntu/+source/apt-xapian-index/+bug/363695. Iotop is awesome and will get the root of the problem though. –  Scaine Nov 12 '10 at 20:12
    
Thank you all guys. Indeed, both iotop and bootchart pointed to ubuntuone-syncdaemon as the responsible of the delay. I don't know whether there's a solution for that. In the meanwhile, I've prevented ubuntuone-launch from autostarting at boot time. –  zuzust Nov 12 '10 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.