Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On the upgrade from 11.10 to 12.04, my XMonad + Unity configuration no longer works. When I attempt to log into this session, I get "failed to load session 'xmonad'". Where can I look to figure out what's going wrong?

share|improve this question

5 Answers 5

What worked for me was to remove the references to unity-2d-launcher entirely from my /usr/share/gnome-session/sessions/xmonad.session (which I had configured for 11.10 the way Mark Hansen suggested):

[GNOME Session]
Name=Xmonad Unity
RequiredComponents=gnome-settings-daemon;
RequiredProviders=windowmanager;panel;
DefaultProvider-windowmanager=xmonad
DefaultProvider-panel=unity-2d-panel

I always use the shellPrompt instead of the unity launcher anyway, so I don't miss the launcher at all.

share|improve this answer

I was able to get the XMonad + Unity configuration to work. I examined the relevant configuration files in /usr/share/xsessions/ and /usr/share/gnome-session/sessions/ (for more info see http://markhansen.co.nz/xmonad-ubuntu-oneiric/), and tried to run the various executables they reference. I thus discovered "gnome-panel" had been uninstalled on the upgrade, so I reinstalled it.

share|improve this answer
    
I installed gnome-panel and I still get failed to load session error –  Raptrex May 12 '12 at 18:30
    
thank you installing gnome paneil worked for me –  KIMA May 25 '12 at 7:16

The best place to look would be in ~/.xsession-errors you could also try /var/log/syslog.

share|improve this answer
    
Didn't see anything in those files. Did find some references to xmonad in the /var/log/lightdm directory, but nothing to do with the reported error message as far as I can tell. –  emchristiansen May 1 '12 at 1:05

The problem is that Unity-2d-launcher no longer exists in Precise. You can change it to unity-2d-shell in gnome-session/sessions/xmonad.session and in ~/.xmonad/xmonad.hs

However, even after doing this, I'm seeing a lot of weird behaviour.

share|improve this answer

Possibly relevant: I recently upgraded and found I needed to delete the file ~/.xmonad/xmonad-x86_64-linux, and all was fine. I run gnome + xmonad, but this step is relevant to any upgrade. See here for more notes on my experience.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.