Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got usb-keys setup to multi-boot different linux images using grub2 loopback.

The standard ubuntu release isos boot fine, however when attempting to use the server iso it will fail to install saying 'unable to detect cd-media for installation'.

the grub.cfg entry;

menuentry "ubuntu-12.04-server-amd64" {
    set isofile="/boot/ubuntu-12.04-server-amd64.iso"
    loopback loop $isofile
    linux (loop)/install/vmlinuz file=$isofile/preseed/ubuntu-server.seed ro noprompt noeject --
    initrd (loop)/install/initrd.gz
}

I've attempted to add the following parameters as the fromiso works for debian images on the key

iso-scan/filename=/boot/ubuntu-12.04-server-amd64.iso
iso-scan/filename=/dev/disk/by-uuid/2859-44B7/boot/ubuntu-12.04-server-amd64.iso
fromiso=/dev/disk/by-uuid/2859-44B7/boot/ubuntu-12.04-server-amd64.iso
share|improve this question
    
I have the exact same problem. I found its trying to mound /dev/sr0 or /dev/sda1 and not finding the "CD" and quitting. –  vkcaspervk May 25 '12 at 18:03
add comment

2 Answers

This worked for me, without using the prompt:

menuentry "Install Ubuntu Server" {
        set isofile="/iso/ubuntu-12.04-server-amd64.iso"
        loopback loop $isofile 
        set gfxpayload=keep
        linux   (loop)/install/vmlinuz  file=/cdrom/preseed/ubuntu-server.seed iso-scan/filename=$isofile quiet --
        initrd  (loop)/install/initrd.gz
}
menuentry "Install in expert mode" {
        set isofile="/iso/ubuntu-12.04-server-amd64.iso"
        loopback loop $isofile 
        set gfxpayload=keep
        linux   (loop)/install/vmlinuz  file=/cdrom/preseed/ubuntu-server.seed iso-scan/filename=$isofile priority=low --
        initrd  (loop)/install/initrd.gz
}
menuentry "Multiple server install with MAAS" {
        set isofile="/iso/ubuntu-12.04-server-amd64.iso"
        loopback loop $isofile 
        set gfxpayload=keep
        linux   (loop)/install/vmlinuz  iso-scan/filename=$isofile modules=maas-enlist-udeb vga=788 initrd=/install/initrd.gz quiet --
        initrd  (loop)/install/initrd.gz
}
menuentry "Check disc for defects" {
        set isofile="/iso/ubuntu-12.04-server-amd64.iso"
        loopback loop $isofile 
        set gfxpayload=keep
        linux   (loop)/install/vmlinuz  iso-scan/filename=$isofile MENU=/bin/cdrom-checker-menu quiet --
        initrd  (loop)/install/initrd.gz
}
menuentry "Rescue a broken system" {
        set isofile="/iso/ubuntu-12.04-server-amd64.iso"
        loopback loop $isofile 
        set gfxpayload=keep
        linux   (loop)/install/vmlinuz  iso-scan/filename=$isofile rescue/enable=true --
        initrd  (loop)/install/initrd.gz
}
share|improve this answer
2  
Could you describe - how you figured out the various kernel boot commands for the different menu entries ? –  Tuxdude Sep 8 '12 at 20:16
add comment

the solution to the problem is an easy one , today i wanted to install ubuntu-12.04 server on my atom server , which obviously doesn't have a cdrom , and i succeeded this way . with this grub configuration :

menuentry "ubuntu-12.04-server-amd64.iso" {

set isofile="/path/to/ubuntu-12.04-server-amd64.iso"
loopback loop (hdX,Y)$isofile
linux (loop)/install/vmlinuz file=$isofile/preseed/ubuntu-server.seed iso-scan/filename=$isofile quiet noeject noprompt splash --
initrd (loop)/install/initrd.gz
} 

, the computer will reach the setup screen , when you are there , press Alt+F2 , and do the following:

mkdir /media/bla
mount /dev/sdXY /media/bla
mkdir /cdrom
mount -o loop,ro -t iso9660 /media/bla/path/to/ubuntu-12.04-server-amd64.iso /cdrom

then press Alt+F1 again , and continue the normal install process , note that , you must not format /dev/sdXY . the installation will work flawlessly , till you reach the configuring apt step , it returned no error , and just didn't work , i simply skipped everything up until installing boot loader on the disk . reboot the system , and voila !!! everything works , the only thing that i've noticed is that , the /etc/apt/sources.conf is empty , you must populate it the way you need it .

hope it helps .

share|improve this answer
    
It's simple as pie. –  Limited Atonement Jul 8 '13 at 13:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.