Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since I made the permanent switch from Vista to Ubuntu i've had wireless connectivity problems. From watching the network manager when it disconnects it seems like it turns off the receiver for some reason. Could it be bad drivers? I used their install software and the site doesn't really offer driver downloads. The adapter is a Netgear WNA1000 if memory serves, and I don't know much about the router except that it's a Motorola Surfboard. And I figure this might help a bit

*-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
      vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 01
       serial: 00:1b:b9:a7:39:a4
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt     100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half     firmware=N/A latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:40 ioport:d800(size=256) memory:feaff000-feafffff memory:feac0000-feadffff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@2:1.1
       logical name: wlan0
       serial: 00:26:f2:8b:fb:38
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=carl9170 driverversion=3.2.0-24-generic-pae firmware=1.9.4  ip=10.0.0.36 link=yes multicast=yes wireless=IEEE 802.11bgn

I have tried installing WICD and it didn't fix the problem. Any help would be greatly appreciated. This problem is greatly limiting what I can do with my computer.

share|improve this question
add comment

2 Answers

I see. I have also had wifi issues with the realtek rtl8188ce : driver rtl8192ce. I tried disabling wirelessN on my router, The only solution that has worked so far today is turning off the wireless power management.

1.gksu gedit /etc/pm/power.d/wireless

2.insert:

#!/bin/sh

/sbin/iwconfig wlan0 power off

  1. sudo chmod +x /etc/pm/power.d/wireless

http://ubuntuforums.org/showthread.php?t=1686641

share|improve this answer
add comment

You could try this:

Type the following in the command line

sudo gedit /etc/nsswitch.conf

This will open the nsswitch.conf file in the text editor. Then simply change the following line

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

to the below line and save the file.

hosts: files dns

http://www.hitxp.com/articles/software/ubuntu-fix-slow-wireless-internet-connection-speed-upgrading-11-04-natty-narwhal/

If this does not work you could try 1. installing the linux driver for your wifi, 2. using ndiswrapper

share|improve this answer
    
This is for the wrong version of ubuntu and doesn't even reference the OPs wireless hardware! –  Jorge Castro May 1 '12 at 0:05
    
this works in 12.04 –  mac1133 May 1 '12 at 3:18
    
Unfortunately it didn't solve the problem, though I am looking into NDISwrapper still, and as far as I know there isn't a linux specific driver for this adapter. –  William Berkenkamp May 1 '12 at 12:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.