Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to fix audio output. NVIDIA GT 520 is the card so HDMI audio. It was working perfectly in 11.10.

Following the steps at: https://help.ubuntu.com/community/So...otingProcedure

Here is my ALSA-INFO: http://pastebin.com/YuBN9t3z

This command does generate sound (good sign!): aplay -D plughw:1,7 /usr/share/sounds/alsa/Front_Center.wav

Added the default PCM line to asound.conf, did not fix anything.

If I configure VLC to play over ALSA on HDMI 1,7 then it works.

No users get sounds, XBMC no sound. I can't even use the System Settings -> Sounds -> Hardware Tab -> Test speakers, none of the options can produce sound.

This makes me believe pulse is toast. I am on hour 6 of trying to fix this.

This is a HTPC, running an upgrade from 11.10 to 12.04. Running kernel 3.2.0-24-generic.

UPDATE Using the pulse audio controls and an application like VLC at the same time I was able to visually see the app playing audio. The problem was it is defaulting to the Built in audio and not the HDMI/DP one. So XBMC and VLC are now set to HDMI/DP output properly.

PROBLEM STILL EXISTS. Nothing understands audio exists by default. They all assume the non existent built in audio is the one I want. Even the gnome sound indicator does not appear, none of the star

share|improve this question
add comment

1 Answer

Did you try downloading the pulse volume control from the software center and changing the profile/configuration?

share|improve this answer
    
pavucontrol? yes this has allowed me to get apps working one at a time. If I get XBMC or VLC playing then open pavucontrol I can see the apps and changes its output to the HDMI/DP option. This works. However all new apps and other users are finding they have to manually adjust this as well. –  Halsafar May 1 '12 at 3:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.