Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So in the last couple of releases of Ubuntu (forget when it started), a window will gray out if it is not responsive/thinking too hard. Maybe "gray out" isn't the best term, it just sort of gets darker. I'm not sure what the exact criterion is to set this off.

For one program in particular (Mathematica 8.0) this gets annoying because the program grays out whenever I rotate a 3D plot for more than a couple of seconds.

Is there a way to turn this feature off, and even better, only for specific programs?

Pictures of before I start rotating, and while I'm rotating are below, in case my description is not clear. This only rarely happens with other programs, so I have no idea how to reproduce it if you don't have Mathematica.

enter image description here enter image description here

share|improve this question
    
By gray out, you means just screen "fade out" and goes to black and display goes off? –  ashutosh Apr 30 '12 at 22:49
    
@ashutosh, Thanks for your question. I do not mean that the whole monitor fades out, I mean that the windows of exactly those programs who are "thinking too hard" get darker. The display does not go off. –  Ian Hincks Apr 30 '12 at 23:37
    
can u please mention your PC specs with graphics cards details? –  ashutosh Apr 30 '12 at 23:49
    
@ashutosh: I don't think that my hardware is relevant? The question is about turning off a software feature. It's an asus laptop using the new i5 gpu and 8GB of RAM. –  Ian Hincks May 1 '12 at 13:09
    
and I don't think its a hardware issue. Issue is only with the grub loader and corrupted MBR. Mbr recovery tools or the method I mentioned can only get it done –  ashutosh May 1 '12 at 13:17
show 1 more comment

1 Answer

up vote 3 down vote accepted

Oh sorry for the thing I took otherway. Now I understood your problem. Graying out unresponsive window is an inbuilt feature with option, which you can turn off. It comes for compiz, which worked for me with the following tweak:

Go to System -> Preferences -> CompizConfig Settings Manager -> Effects -> Fading Windows and then just to option for Dim Unresponsive Window and you can set the option as per your requirement.

More changes about compiz can be found here. Not sure about gnome.

share|improve this answer
    
Thank you! I'm so bad at searching through CCSM and finding what I want. –  Ian Hincks May 2 '12 at 23:09
    
and thank you for You have increasing my reputation which I lost being mad at people. –  ashutosh May 2 '12 at 23:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.