Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since upgrading to 12.04, I've lost my custom super-s shortcut that I've been using through xbindkeys. Moreover, assigning super-s to commands using the "keyboard shortcuts" settings panel fails to take effect. I am assuming some part of 12.04 UI is stealing that binding; I am running Xmonad using Gnome's fallback mode, so I have no idea what (if anything) super-s is supposed to do on 12.04.

What is stealing the super-s binding and how can I stop it?

share|improve this question
1  
Same problem for me. Not working <Super> with c/z/b for pause-play/previous trac/next trac. Nobody knows why :( It worked in 11.10. –  piotrekkr Apr 30 '12 at 20:35
    
possible duplicate of Can't bind gnome-do to Super + Space or Ctrl+Alt+Space –  hbdgaf Apr 30 '12 at 21:50
    
@aking1012: Linked question suggests that "Unity recently changed to grab the super key entirely" but doesn't offer a way of disabling this insane behavior. –  Leo Alekseyev May 1 '12 at 1:38
    
Yes, the impression I got from your question was that you wanted to restore your bindings involving 'super'. You can't set bindings to 'super' anything. They all belong to unity. If you're looking for the How would I do it if I want to break things you're talking about editing and recompiling Unity(don't). If you think it's a bad behaviour file a bug: launchpad.net/unity –  hbdgaf May 1 '12 at 5:39

1 Answer 1

If you're in Unity 3D, you can go to

gff --no-gui -setparam="CCSM/Expo/Keyboard\ Shortcut/*" setflag("disabled")

OR in human terms/you don't know what gff is: Open up CompizConfig-Settings-Manager, then go to "Expo", then inside the first tab "Keybinds" there should be a keybind called "Activate", click on the pencil next to it, and write "disabled"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.