Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using this laptop with Ubuntu/(& variants of Ubuntu) for three or four years. I've never been able to get the microphone to work - internal or the jack - though I've followed a variety of leads. The strange thing is that if I plug in a mic, while Audacity (or similar app) is recording, something like a click can be heard but nothing else. The mic seems to be recognized, but I've never been able to record. I'd really like to use this laptop with Skype (and with the microphone in general).

Currently Using: Xubuntu 11.10/Ubuntu 12.04 Dual Partition

More Details: Using Xubuntu 11.10. If I use Pulse Audio Volume Control and crank the Left & Right Microphone volume bars as far as they will go, Audacity will record what Clementine is playing, but it is barely, barely, barely audible. I've also cranked the volume in ALSAMIXER, but this doesn't help.

The solution offered for the HP Pavilion DV1000 and Skype, offered here, no longer appears to work.

share|improve this question

1 Answer 1

I solved "External" mic problems for Ubuntu 12.04.

I don't have internal mic for my dv1000 but the internal mic should work too.

Though I cannot get my dv1000 for Ubuntu 10.04 LTS work at all till now. (No matter with all possible how to, including updating alsa ppa.)


  1. Open a Terminal Ctrl+Alt+T

  2. Enter this command: gksu gedit /etc/modprobe.d/alsa-base.conf

  3. Copy the below "option" and add it to the last line of that alsa-base.conf file:

    options snd-hda-intel model=auto enable=yes
    
  4. Reboot

  5. Go to "Sound" and go to "input" setting.

  6. "Insert" your external microphone (ext.mic) jack into the "Mic in Jack hole" of the dv1000.

    If you don't insert the ext.mic, the Line In (ext.Mic) option will not be there.

  7. You must select Line In Input (it is for our ext.mic), in order to enable External Mic.

  8. Don't forget to un-mute the "mute" microphone option, if it is still checked. (mine is always muted)

  9. Test new setting with Sound Recorder.

Source: This is taken from http://ubuntuforums.org/showthread.php?t=2018599 with an additional warning in step 6, and slight rewording elsewhere.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.