Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Xubuntu and I just want to make a simple modification in the configuration of the network-manager for the openvpn connection, and it requires me to authenticate. Here is what is going on : I go in the network-manager applet, I click on "vpn", then "modify", then I uncheck the box "connect automatically", but I can't click on apply, and when I hover the mouse over the "apply" button it says I should authenticate. More importantly the vpn connection works when I first set it up, but as soon as I restart the computer, my vpn connection fails and I am unable to make modifications to the configuration of the vpn in gnome network-manager.

share|improve this question
    
Don't you over complicate things? Why not just type in the password to authenticate? –  mikewhatever Apr 30 '12 at 18:48
    
It doesn't ask directly for a password, it's the message I get when I hover the mouse over the "apply" button and I can't click on it... –  Pascal Apr 30 '12 at 18:59
    
That usually means that the network Manager doesn't know how to deal with the supplied info - might be an 'illegal' character or unexpected space somewhere. By the way, it runs as root by default. –  mikewhatever Apr 30 '12 at 19:10
    
I go in the network-manager applet, I click on "vpn", then "modify", then I uncheck the box "connect automatically", but I can't click on apply, and when I hover the mouse over the "apply" button it says I should authenticate. –  Pascal Apr 30 '12 at 19:27
    
You might want to add that info to the question, to make it clearer. –  mikewhatever Apr 30 '12 at 19:32
show 1 more comment

1 Answer 1

I found what was keeping me from performing the modifications and probably also why the connection would fail after reboot. When I imported the configuration file, I had to uncheck the option to set it for "all users", which is enabled by default. Now vpn works and I can make modifications.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.