Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I clean-installed 12.04 after using 10.10.

When using SSHFS, everything is now very slow. (I am on very fast ethernet, and also tried on wireless).

e.g. if I:

sshfs user@XXX.YYY.ZZZ:/home/user/directory ~/Directory
cd ~/Directory
nautilus .

nautilus will take almost a minute to open. Or if I open a file with gedit or geany it also takes nearly a minute. These things used to take a couple seconds when I did them in 10.10. Any ideas?

Edit: To clarify a few things - ssh itself is quite fast. I've done an identical sshfs on the same network from an ubuntu 10.04 machine and it is quite fast. On 12.04, everything in the sshfs mounted directory is slow - even to just 'ls' is very slow. Even tab completing a command is very slow when not referring to the directory contents.

share|improve this question

This seems to be related to ipv6. It worked for me after I disabled ipv6. Hopefully somebody else can comment as to why ipv6. In my case, forwarded X sessions were also slow, in addition to the sshfs misery.

Here's the workaround I used:

echo 'net.ipv6.conf.all.disable_ipv6 = 1' >> /etc/sysctl.conf
sysctl -p

I also added "ipv6.disable=1" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and run update-grub, then rebooted.

Finally, if thereafter it doesn't work at all, add "AddressFamily inet" above ListenAddress in the other machine's /etc/ssh/sshd_config and restart sshd. For some reason, the default addressfamily of "any" doesn't work in that case, even when you specify as a listenaddress. Granted, the other end is running ssh 5.5.

share|improve this answer
I've seen similar issues in Java applications in the past... I wish I understood better why IPv6 causes problems like this. – djangofan May 3 '12 at 22:37
This is unfortunate, because I've run into this issue, and disabling IPv6 is completely unacceptable. – Michael Hampton Jan 12 '13 at 6:49
I manually added net.ipv6.conf.all.disable_ipv6 = 1 to the end of the /etc/sysctl.conf file and my direct nautilus transfer is still going incredibly slow. It always starts out at a really low < 1kB/s and then slowly climbs upwards. Its been going for a couple of minutes now and seems to cap out at 5.2 kB/sec. Is this to be expected? Using filezilla with 'sftp' which is really just scp, it achieves much, much higher transfer speeds. – Programster May 31 '13 at 16:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.